Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Why are the failing addresses in Memtest86+ higher than my total memory?

I'm having some hardware related computer issues lately. My desktop contains an Intel Q6600, Gigabyte P35-DS3R motherboard, Sapphire HD7850 and 4 dimms of 1GB Kingston memory. HDD is a OCZ Vertex2 120GB.

I was in the belief you need to reinstall Windows7 to configure the SATA IDE mode to AHCI. So I changed the SATA mode, booted windows CD and then the trouble starts.

I tried installing windows. Screen turned black when expanding files. Installation stopped, no CD activity, harddrive LED remained lit. Retried several times, reformatting drive everytime. Eventually I didn't reformat it, and for some reason it continued with the previous installation(?). Anyway, it completed but my first suspect was the SSD.

Scanned that with a Hirens boot CD. Didn't turn up any bad or worn out sectors. SMART data is OK. I can boot windows from it. However, Windows got a 'black out' <2 minutes too. I placed the drive in another PC with very similar specs (only running another motherboard from Asus) and Windows ran fine and stable. So it must be something on the graphics/motherboard/proccesor/memory. I replaced the graphics card with a Nvidia 8800GT.. No difference, still black outs. Sound also stopped when it black outs. It doesn't reboot by itself, if I press reset the PC seems to shut down completely and reboot moments later. Very similar behaviour if I change major BIOS settings..

So I updated my BIOS firmware. Eureka! I thought, it works again. But I wasn't sure so I ran memtest86+ (v4.2) and got errors. One error at 3582.9MB. Removed one dim. Error went to 3070.9MB. Removed another dim, 2046.9MB. Left one dim in, 1022.9MB. So the last one must be broken. So I pulled it out and placed the other 3, in the assumption those weren't faulty.

I worked my way up to this last dim because it's underneath my Scythe Mugen 2, and could only be removed (for placing it I would need to remove the cooler, and for that I need to remove the motherboard and undo all my cabling, ugh). Anyway, the slot nor the dim seemed to be the cause. Scanned again with 3 dims: error at 3070.9MB. I've seen that address before.. One dim in slot 2 or 3; error at 1022.9MB.

Now comes my question: memtest86+ indicates I have got 3069MB of memory (3 dims). The error is at 3070.9MB. How can this happen? What is broken?

My suspection is that the memory is fine but either the CPU or motherboard is damaged. The CPU has been running quite hot for some time before I bought this Scythe Mugen 2. With 'Quite Hot' I mean 70C idle and 95C stressed (junction temperature). I believe Tj_max is estimated at 100C, but I suspected that can't be good.

I don't believe this has something to do with the SATA mode. I think the issue was always there, but format was such a system critical part it popped up heads on. Strange though that such severe computer problems (like black screens all the time) pop up when I only change the SATA mode. Changing it back to IDE didn't help, by the way.

I've tried several memory configurations, with stripping out modules and testing 1 module in 1 slot. It all threw errors, always at the addresses I've mentioned (depends how much modules I got installed). The modules it self are 1GB; so thats 1024MB. Where is the last 3MB going to? System reserve? If it is system reserve, why is it at the end ?

share|improve this question

marked as duplicate by Bob, Diogo, bwDraco, Simon Sheehan, Dennis Jul 15 '12 at 4:47

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

You need to use 1024 instead of 1GB in your calculations. – Ramhound Jun 6 '12 at 18:55
"The modules are 1GB; so thats 1024MB". I figured, 3*1024=3072MB. Memtest reports 3069MB memory size. Error at 3070.9MB. The related question is answered for systems with over 4GB. I am running this under 4GB, even at 1GB this occurs. – Hans Jun 6 '12 at 19:02

Although Memtest86+ does run in real-mode, unless you have an actual hexadecimal address of the memory byte in question, you can't judge the error location as measured in megabytes (which is a million times bigger than what you're actually trying to measure). Furthermore, it's possible for memory errors to not be constrained to a single location due to the physical characteristics of DRAM itself.

Check your DIMMs one at a time to see which one is bad; it's possible that more than one is the problem. It's also possible that the memory controller on the motherboard itself is faulty, but it's best to check the DIMMs individually first (if it passes with certain DIMMs consistently, the motherboard is probably fine).

Finally, 70C at idle is way too hot, let alone hitting 95C under load. I'm surprised your computer didn't shut itself off; some motherboards will force a system shutdown somewhere in the 80-100C range. The Q6600 has a maximum case temperature of only 71C. It's possible your CPU is also damaged, but most processors can withstand those temperatures (albeit not for prolonged periods of time). You should first fix your CPU heatsink (it should hit a maximum temperature in the 60's), and then run a CPU-specific test (like Prime95) to ensure the CPU is still functioning correctly.

share|improve this answer
As I said, those temperatures were before I got the new cooler. It now runs 30-35C idle. I am mentioning it because it may have caused damage, but I am sure whether it's related. I was able to run the CPU at 3.0GHz after the hot temperatures. The PC never shut it self off, because the temperatures I read were junction temperatures, which is not case temperature. Anyway, I will do some more memtests. I suspect my motherboard too. Hopefully I can arrange something to test this memory in another PC. If I recall correctly, the address with 1GB was 0x3FFEE388. Will need to check & write it down. – Hans Jun 6 '12 at 19:55
A damaged CPU sounds likely. Try testing the CPU and memory (separately) in a different computer, and see what happens. – Jim Fell Jun 6 '12 at 20:08

Not the answer you're looking for? Browse other questions tagged .