Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a wireless router/modem (Router 1) in my living room. This is connected to the internet (cable). Wireless is disabled as the router has a terrible wireless range. My Xbox is connected via ethernet to Router 1. Another LAN output from Router 1 connects to a powerline adapter. Router 1 acts as a DHCP server on 192.168.0.x and has the IP 192.168.0.1

In a second room I have Router 2. This has the powerline feed from Router 1 going into the WAN socket. This router runs the Tomato Firmware and acts as a wireless router for the rest of the house using the IP range 192.168.1.x. Router 2 IP is 192.168.1.1. My Mac is connected to Router 2 using a LAN cable and has the IP 192.168.0.133. Several mobile devices need wireless access. I want an ethernet connection to my Mac, not wireless.

I should be able to use software like Connect360 to share media from my Mac to the XBox but the XBox does not see my Mac. I can ping 192.168.0.1 from the Mac.

Is this possible using my current setup? If so, how?

share|improve this question
    
Can you clarify what you mean by "I want an ethernet connection to my Mac, not wireless"? – Hassan Jun 6 '12 at 20:21
    
That is what I currently have. I just wrote that in case someone said 'oh just make a big wireless network' . I prefer to have a proper wired LAN connection on my main computer. The powerline connection via the two routers gives me a reliable and fast connection. I don't want to change that. – codecowboy Jun 6 '12 at 21:55
    
Do you have the firewall on router 2 turned off? – Hassan Jun 6 '12 at 22:00
    
No. I don't currently have any rules for whatever file sharing / streaming protocol XBox uses. – codecowboy Jun 7 '12 at 4:07
    
Well it's a possibility that the firewall on router 2 is causing the connection to be blocked. – Hassan Jun 7 '12 at 4:11

So, I got this working from reading a few other threads. Here's what I did

1.Disabled DHCP on Router 2. 2.Set Router 2 IP to 192.168.0.2 3.Set Router 1 to always give Router 2 the IP of 192.168.0.2. 4.Moved the powerline cable from the Internet/WAN port to a standard port on Router 2 (Don't know why I had to do this)

So Router 1 is now serving IP addresses via router 2 to wireless devices and my Xbox can now talk to my Mac.

My only remaining problem is that I can no longer access the Router 2 (running Tomato) homepage in a browser at 192.168.0.2. I can see it in the attached devices on Router 1 though. If anyone can explain a) exactly why the setup now works and b) why I can't access Router 2 in a browser I would greatly appreciate it!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .