Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to use two versions of Firefox (11 and 13) on OS X Lion.

I don't especially want to run two versions at the same time. I want to be able to run the version 11 when I choose the version 11 via the profile manager. The same for the version 13.

Every time, I want to launch the version 11, the launcher launches the version 13...

When I select the version 11 via the profile manager, Firefox 13 is launched.

I created 2 automators apps ( and to launch Firefox :

/Applications/ -no-remote -P FF11 &> /dev/null & /Applications/ -no-remote -P FF13 &> /dev/null &

Any help would be greatly appreciated.

Thanks in advance.

share|improve this question

You cannot choose which version to run via the profile manager. When you see the profile manager, a specific version of Firefox already has been started. You need to explicitly start the version you want to use. While different profiles are not absolutely necessary. I would recommend to use different profiles however, as there might be some changes to certain file formats between the versions and downgrading could break something.

Note that Firefox 11 is end of life and there are known security vulnerabilites: - So usually there is no good reason to use such a version for anything. If you are developing websites or extensions, you rather should test with Firefox 10 ESR which is still supported.

share|improve this answer
Thanks Gurken for the explanation. I ditched FF11 and tried FF10. Same results at first. I tried the profile manager app launched by Mozilla (still in beta). Same results. Today I can launch FF10 and FF13 at the same time but I still wouldn't say I have a stable and reliable way of doing this. Some time, clicking on launches FF13. – politicus Jun 7 '12 at 12:49
Does this happen only when there is already an instance of Firefox running? It should be unlikely that the results of your repeated attempts are not reproducible. Also check if this also happens when you launch Firefox from the terminal with the given parameters. – Gurken Papst Jun 7 '12 at 16:42
Hi Gurken, I retried launching version 11 and 13 many times using Multifirefox. Went smoothly every time. As I installed a second firefox version because I wanted to use a specific extension, that this extension is now supported by both firefox 11 and firefox 13 I think I am less concerned about the bug I had and that seems to have disappeared. Awesome + Thanks for your help. – politicus Jun 10 '12 at 9:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .