Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to install Vista SP2, it fails and gives me the error:

error_smi_primitive_installer_failed(0x8007371c)

It happens if I try it through Windows Update or with the standalone installation.

Does anybody know how to fix this?

share|improve this question
    
I ended up installing Windows 7. That fixed several problems. I never could fix the error, and didn't want to go through the trouble of trying to repair Vista. –  Jim Dec 2 '09 at 20:42
    
It may not be relevant anymore, but since people posted some valid solutions, it worth to keep it –  Ivo Flipse Jan 19 '10 at 12:10
add comment

2 Answers

up vote 2 down vote accepted

I know you've "solved" this problem by installing Windows 7 instead, but in case anyone comes across this question needing help...

The error you received was that the SMI Primitive Installer was failing. According to PC-Library:

Error 14108 - Error Code 0x371C

Windows Error Code 14108: 'ERROR_SMI_PRIMITIVE_INSTALLER_FAILED'

Description of Error: The SMI primitive installer failed during setup or servicing. Errors on your system may be caused by invalid registry entries and outdated or corrupt drivers.

It looks like the process needed to fix this error is to use the Vista Installation DVD to either do a repair or a reinstallation. This problem seems to be deeply rooted in problems with a lot of important Windows .dll files. This user here was able to fix the problem with a reinstallation of Windows, which preserved all his files. As always, don't forget to back up your data while trying to fix this!

share|improve this answer
add comment

This article contains answers to exactly your problem supplied by Microsoft Support :
"Vista SP2 Error 8007371c".

share|improve this answer
    
Which was not solved for the user on the page you linked to. –  Macha Oct 17 '09 at 11:13
    
There was a solution suggested, which I thought was worth trying. If it doesn't work, I suggest that the OP verify that he has the right installer. Otherwise, the only advice I can give is to reformat the disk and do a full install. –  harrymc Oct 17 '09 at 12:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.