Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a 6in4 ipv6 connection from a linux box to a broker. I use gogoc to establish the connection to the broker, and radvd to advertise the route to clients on the network.

All this appears to work, the problem is that I have a Windows 7 machine on the same network, and it is advertising itself as a ipv6 router. Which it is not.

This is output from radvdump:

 #
# radvd configuration generated by radvdump 1.8.5
# based on Router Advertisement from [snip]:ea2
# received by interface eth0
#

interface eth0
{
        AdvSendAdvert on;
        # Note: {Min,Max}RtrAdvInterval cannot be obtained with radvdump
        AdvManagedFlag on;
        AdvOtherConfigFlag on;
        AdvReachableTime 0;
        AdvRetransTimer 0;
        AdvCurHopLimit 0;
        AdvDefaultLifetime 1800;
        AdvHomeAgentFlag off;
        AdvDefaultPreference medium;
        AdvSourceLLAddress on;
        AdvLinkMTU 1500;
}; # End of interface definition
#
# radvd configuration generated by radvdump 1.8.5
# based on Router Advertisement from [snip]:1121
# received by interface eth0
#

interface eth0
{
        AdvSendAdvert on;
        # Note: {Min,Max}RtrAdvInterval cannot be obtained with radvdump
        AdvManagedFlag off;
        AdvOtherConfigFlag off;
        AdvReachableTime 0;
        AdvRetransTimer 0;
        AdvCurHopLimit 64;
        AdvDefaultLifetime 1800;
        AdvHomeAgentFlag off;
        AdvDefaultPreference medium;
        AdvLinkMTU 1280;
        AdvSourceLLAddress on;

        prefix [snip]::/64
        {
                AdvValidLifetime 86400;
                AdvPreferredLifetime 14400;
                AdvOnLink on;
                AdvAutonomous on;
                AdvRouterAddr off;
        }; # End of prefix definition

}; # End of interface definition

And I end up with two routes:

$ ip -6 route
[snip]::/64 dev eth0  proto kernel  metric 256  expires 86117sec
fe80::/64 dev eth0  proto kernel  metric 256
default via [snip]:ea2 dev eth0  proto kernel  metric 1024  expires 1492sec
default via [snip]:1121 dev eth0  proto kernel  metric 1024  expires 1506sec

The ea2 route is to the Windows7 box. It doesn't have a router installed, and doesn't have any tun/tap interfaces. I can't see why it is doing this.

I could disable ipv6 on it, but I want it to be a client, not a router.

Update: The IP Helper service (Provides tunnel connectivity using IPv6 transition technologies (6to4, ISATAP, Port Proxy, and Teredo), and IP-HTTPS. If this service is stopped, the computer will not have the enhanced connectivity benefits that these technologies offer.) seems to be the culprit, as if it is stopped, I don't get the routes advertised. So my question is now more specifically "why is IP Helper announcing routes?".

share|improve this question

2 Answers 2

  • Run elevated netsh and go to interface ipv6.

  • Check if show route lists any published routes.

  • If it does, unpublish them with set route ::/0 "Local Area Connection" publish=no.

However, according to the radvdump output, your Windows box doesn't advertise any prefixes, so I don't see why would Linux add a default route through it.

  • Use show interface verbose to list network interfaces; look for "Sends Router Advertisements" or similar values.

  • Use set interface "Local Area Connection forward=disable advertise=disable to disable IPv6 forwarding and router advertisements.

share|improve this answer
    
No published routes. Yeah I agree - no prefix, yet it is being accepted as a default. Weird behaviour. –  Paul Jun 7 '12 at 9:19
    
@Paul: I added two commands I had forgot; they'll have to be adapted for Win7, but should completely disable the advertisements. –  grawity Jun 7 '12 at 9:25
    
I am not familiar with the show interface verbose command - it doesn't work at any of the levels I tried. I have found a way to stop the advertisements (I updated the question) - but my question is why is Windows doing this at all. –  Paul Jun 7 '12 at 9:33

Have you tried telling the Windows 7 machine where the default route lives or removing the bad from the router? Unless you have ICS turned on it should be purely a client.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.