Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In windows 7 you have the busy icon that is a little blue wheel spinning beside the cursor when it is doing something. It has started to spin for about a second every 3-5 seconds. There is noting running that I can tell on the computer to cause the busy icon. It gets very annoying and I am not sure what to do to get it to stop. Ideas?

Running a CPU Usage Gadget says I have less than 5% of the CPU being use and I have over 6GB of RAM free. (I have 8GB total) I am running a 3.6 GHZ AMD FX 4100 processor.

EDIT- What I am actually seeing is the working in background pointer (the pointer is still visible beside the busy icon).

EDIT 2 - After realizing this happened with the printer installation I turned on the the printer and the busy icon stopped. The printer is setup wirelessly. How do I stop Windows from (I guess) checking for the printer? That is what I assume it is doing. I am using a HP Officejet 8600

share|improve this question
    
Is this the first time you encounter this problem? When did this problem start? –  sammyg Jun 7 '12 at 15:39
    
Recently installed drivers can cause this type of problems. –  sammyg Jun 7 '12 at 16:06
    
As of EDIT 2, if this is the situation I would suggest you to remove the printer and then add it again. I have edited my original answer to give you other possible solutions to work with. If removing and then adding the printer again doesn't solve the problem then you want to completely uninstall it which not only removes the printer from the list of printers but also uninstalls the drivers and any associated software that came with the printer. Then you want to install it again. This time I would suggest you skip installing unnecessary bundle software that came with it. –  sammyg Jun 7 '12 at 17:12
    
By the way, is this printer connected to a print server? Or is it connected to a router? Maybe it's connected to a computer with a USB cable on one end, and then shared across the network wirelessly to your computer at the other end? Depending on how it is connected to the network the installation procedure may be a little bit different. Like for instance, if it is connected to another computer and then shared from that computer then the drivers need to be installed on that computer, not yours. –  sammyg Jun 7 '12 at 17:21
    
To give you an idea of how to install a wireless printer, take a look at washburnlaw.edu/technology/howto/printervista.php guide or pcworld.com/article/212204/…. You want to make sure you install the printer properly, just in case, and to avoid any surprises like this one. If you need help with this please make it a new question. –  sammyg Jun 7 '12 at 17:35
add comment

8 Answers

up vote 5 down vote accepted

This issue was caused by the installation of the HP Officeject Pro 8600. I believe what was happening is HP's software was attempting to connect to to the printer. When it could not it kept checking. This was happening from boot so I went into msconfig and saw that HP had two applications running at startup:

hpwuSchd Application - Which from the file path I believe is HP's update software.

HP Digital Imaging - is the other program running. I do not know exactly what HP Digital Imaging does but when I disabled it in the startup (I left the other one running). The issue is no longer there. As far as I can tell the printer still functions properly without this running. (IE: It prints but I do not know how scan etc will function).

share|improve this answer
    
I'm glad to hear you solved this issue. The hpwuschd.exe is a process belonging to the Hewlett Packard Software Update Scheduler which checks and displays driver update information. Windows Update will often offer driver updates specific to your PC hardware but it may be worth to check for new driver versions manually. Just go to the HP support center and see if there are any new drivers for your device. –  sammyg Jun 7 '12 at 19:47
    
HP includes the Digital Imaging Monitor software to provide functionality to the custom buttons that print, scan, email and otherwise manipulate documents on HP devices. So you may actually want to do the opposite and disable the hpwuSchd and let this one run freely. That is, assuming that you want to be able to i.e. scan and email a document by the touch of a button on the printer. I personally don't mind scanning and attaching the document to an email manually. –  sammyg Jun 7 '12 at 19:51
    
You may actually have some OCR software as well bundled with the printer for character recognition. You might loose this feature if you disable or choose not to install all of the programs that came with the printer. By the way, you may want to try a different driver software version. If you installed from the supplied CD last time you should try downloading the latest version from HP. –  sammyg Jun 7 '12 at 19:56
    
@Sammy - It does have some OCR software, when I use the printer I can always manually start the program not started if I need it. And I did update the drivers from HP. –  Lynda Jun 7 '12 at 20:46
add comment

HP has a youtube video on this issue when there is a wifi printer connection to one of their printers and their software is also installed on your computer. If this is your situation, read on.

I had this problem until I followed the instructions on the video. Basically, with the printer on, you go to the printer's IP address with your browser and set the IPv4 IP on the printer from automatically assigned to a fixed IP address. Although the video instructs you to selected an IP address outside of your router's DHCP range, I elected to fix it at the same IP address my router always assigns to it. Worked like a charm. See: http://www.youtube.com/watch?v=llYNMNKJMX4 No more constantly spinning cursor.

share|improve this answer
add comment

You can try changing your default cursor in Windows 7.

  1. Press Win+R and type main.cpl and press Enter.
  2. Click Pointers and from the Scheme list pick a pointer that's different from the one that's already in use. (Remember which pointer you had.)
  3. Click Use Default button.
  4. Now pick the pointer that you had before and click Use Default button again.

If that doesn't help, you can try changing the theme in Windows 7.

  1. Press Win+R and type control /name Microsoft.Personalization and press Enter.
  2. Click on Theme.
  3. Pick a theme that's different from the one that's currently in use and apply changes.
  4. Now go back to the default Windows 7 theme and apply changes.

Note: Changes should be applied automatically in Windows 7 as soon as you switch to a different theme.

If that doesn't help, you can try removing the wireless printer from the computer you installed it on.

  1. Press Win+R and type control /name Microsoft.DevicesAndPrinters and press Enter.
  2. Right-click the printer that you want to remove, and then click Remove device. Click Yes to confirm.

Note: To add the printer, go to Devices and Printers and click on the button Add a device or right-click on the white area and choose Add a device. Remember, the steps given above only remove the printer from the list of printers. Since you have already installed the driver for this printer once and you will not have to do it again. All you need to do is select the make and model of the printer.

share|improve this answer
    
Thanks, it is still happening, I should calrify here after seeing the temrs what I am actually seeing is Working in Background Pointer –  Lynda Jun 7 '12 at 15:55
    
Did you change the theme in Windows 7? If so, you can try setting the default Windows 7 theme. If not, you can change the theme first and then change it back to default setting. –  sammyg Jun 7 '12 at 16:09
    
Thanks for the help, the printer is connected to a router and has no USB cord connected. The main computer it is connected to is mine then it is connected to another computer. I will attempt to uninstall the software that was installed then re-install and see what happens. –  Lynda Jun 7 '12 at 17:42
    
I was able to solve the issue, see my answer for what I did. Thanks for your help. –  Lynda Jun 7 '12 at 19:11
add comment

I had been having this problem also, incredibly annoying for whatever reason... then it dawned on me and I had the brilliant idea to go into mouse settings and change the pointer option for what pointer icon is used for the 'Busy in Background' or whatever it's called, just changed that to the standard one. So now whenever and whatever it does in the background I don't have to see it on my arrow.

share|improve this answer
    
interesting solution... but the busy icon is meant for the use to know that the system is waiting on some important action to happen... changing the icon will suppress this indication for good... :) –  user1055604 Apr 21 '13 at 7:18
add comment

I had the same problem.
For a really quick solution I just turned the printer on, and the spinning wheel went away within 30 seconds.

share|improve this answer
add comment

If you are on Google Chrome, try disabling the extensions. If that works, bring them back one at a time. It worked for me.

share|improve this answer
add comment

I had to remove the OneNote printer from Devices. That solved the problem for me.

I had previously tried removing my old Canon printer drivers and reinstalling them, but that didn’t work.

Only OneNote seems to have the problem, so my guess is that Word was trying to autosave the document 10 times/sec.

share|improve this answer
add comment

For a really dumb solution - our HP wireless printer is located in a separate room. I was getting this busy icon problem and eventually went to look at the printer to find our cleaner had unplugged it yesterday to use the power socket!

Not expecting anyone to be as dozy as me but it does show that HP software is the cause and it clearly won't desist until someone pays attention to it.

share|improve this answer
    
Can you expand on this? –  DragonLord Sep 23 '12 at 2:53
add comment

protected by Community Oct 2 '13 at 3:46

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.