Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have set up FTP-server (Filezilla), when I try to connect to it I get asked for login, so I log in, then I can see the connection is entering passive mode..... and nothing happens. (I can see in the Server Interface when incorrect login params are entered, this is not the case.)

When I am lucky enough to get the files listed and when the download starts then the speed is just OK. That happens rarely tho. :(

I tried to disable my antivirus, even though I don't think that would be the issue.

Any hints please?

I have created inbound rules for both TCP and UDP ports.

share|improve this question
Have you tried a different FTP client program? – Ramhound Jun 7 '12 at 20:47
yes, Chrome, Windows Explorer, my buddies from elsewhere tested the connection to me too – Jaroslav Záruba Jun 7 '12 at 21:29
up vote 0 down vote accepted

Sooo, the trouble was that I did not open ports that are used for passive mode. For these forwarding must be set up on router and, obviously, they need to be open in the firewall.

share|improve this answer

I had the same problem - one of my colleagues works at home and she was unable to get the directory listing. She waited 15 minutes and still nothing. When she's lucky and gets the directory listing, she can download files at a relatively high speed. In my case I have to wait about 15 seconds to get directories, so the connection worked between my home computer and the server.

The server is running FileZilla v0.9.41 beta on Windows XP, the client is Total Commander v8.0 on Windows 7. She has a 120 Mbps connection. After reading some articles I changed the server's parameters as follows:

  • I increased "Internal transfer buffer size" (can be found at Edit → Settings → Miscellaneous) from 32768 to 262144
  • I increased "Socket buffer size" from 65536 to 262144
  • I enabled "MODE Z" filetransfer compression (Edit → Settings → Filetransfer compression)

Since then it's been working like a charm.

However I read that you have to test transfer speeds at different buffer sizes (65536, 131072, 262144, 524288) and after that you can choose the best buffer size value (I heard some machines with slow connections don't like high buffer size values while others don't work with low values).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .