Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I run on Debian Linux across 3 monitors and using 3 separate X Servers. I.e. the is an application menu on each screen and although I can not drag and drop between the monitors I am so used to where things are that drag and drop in a non issue.

For a while now I've been trying to get Chrome to open separate instances on each X Server. However I can not seem to get it going. Basically if I open Chrome on the first X Server and subsequently try to open Chrome on the second X Server, the Chrome window still opens on the first X Server.

Does anyone have a solution for this?

Gary

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

After some further research I came across this bug report and interestingly enough Comment 13 suggests to change /usr/bin/google-chrome to:

#!/bin/sh
exec /opt/google/chrome/google-chrome --enable-greasemonkey --enable-user-scripts --enable-extensions --user-data-dir=~/.config/google-chrome/$DISPLAY "$@"

So rather than overwriting the /usr/bin/google-chrome I created a ~/bin/chrome shell script put the command in there, and used that to launch Chrome on each X Server Screen and it worked perfectly with each X Server now having it's own version of Chrome.

As mentioned in the comment on the bug report it seems to create a new profile for each display. However for me it's actually better, as 1 display I tend to use for email/communication/etc hence a set of Chrome plug-ins, another screen for development work and hence another set of Chrome plug-ins, etc.

And finally if you need to sync book marks, I use xmarks with a plugin installed in each Chrome profile.

Anyway hope this helps someone!

share|improve this answer
add comment

The same goes to firefox as well. I made my changes below:

Multiuser Firefox | Multiple users allowed after this changes are applied.

/usr/bin/firefox -> /opt/firefox/multiuser-firefox

The command/script is as follows:

#!/bin/sh
exec /opt/firefox/firefox --enable-greasemonkey --enable-user-scripts --enable-extensions --user-data-dir=~/.mozilla/$DISPLAY "$@"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.