Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am new to urxvt (moved from gnome-terminal -> Ubuntu 12.04 refugee). I am used to having environment variables expand in gnome-terminal by default

Suppose that I have an environment variable "FOO_PATH" set up for "/home/foo/".

When I type $FOO_PATH/ , I do not get an expansion and/or a listing of items in $FOO_PATH.

How do I achieve this in {u}rxvt ? Thanks for your attention.

RRS

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

What you describe sounds like a shell issue, and nothing that has to do with Urxvt/Gnome Terminal. Probably Bash is used in both cases - perhaps you are missing the bash-completion package or an equivalent in your current setup (it seems like you have left Ubuntu, but you don't say what you use now, so I can't give more specific tips). Try installing that.

share|improve this answer
    
I have not left Ubuntu. I moved from GNOME to XFCE. I think you are right about $bash-completion$. I am not the admin and it seems to be the result of a botched upgrade from 10.04->12.04. Thanks. –  boffin Jun 8 '12 at 13:14
add comment

This is about direxpand option. $ shopt -s direxpand and $FOO_PATH/ will be expanded by TAB.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.