Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Is there a way to access connecting to other wifi networks in range?

I have an office and there are few wifi networks in range. Some of them are not password protected and invariably I get connected to that wifi first. I have talked to the person who owns that wifi. But he is somehow not listening about adding password to his network.

So, is there a way I can block that Wifi network completely so that I do not connect to it?

I have Win 7 and Mac at my office.

share|improve this question
    
Have you tried turning those networks in your 'list of available networks' to manual, so that you automatically connect to something else first? –  Rhys Gibson Jun 8 '12 at 5:45
    
From where do I do that? –  meetpd Jun 8 '12 at 5:46
    
haven't got a Win 7 box in front of me, but in your control panel, select 'manage wireless networks'. From there you should get an option to change the order of the preferred networks by dragging them around –  Rhys Gibson Jun 8 '12 at 5:49
    
Your neighbor was correct to ignore you. It's his right to run an open network if he wants, and there's no reason it should cause any problems for anyone else. It's good that you're trying to learn how to configure Wi-Fi on your clients. –  Spiff Jun 8 '12 at 11:15

3 Answers 3

up vote 1 down vote accepted

On the Mac, it's in System Preferences > Network > Wi-Fi.

There's the "Ask to join new networks" checkbox which you might want to un-check. Then under "Advanced > Wi-Fi", you might want to remove your neighbors' networks from the Preferred Networks list, and perhaps un-check "Remember networks this computer has joined", and perhaps check "Require administrator password to: [√] Change networks".

Even if you had never even looked for these settings and thus left them at their defaults, your Mac wouldn't have joined those other networks unless at some point you told it to (either explicitly, or by picking it from the list presented when your normal networks weren't found).

By the way, your network and your neighbors' networks all have unique names, right? It's not like you've all left your networks with default names like "Linksys" or something silly like that, right? If you haven't given your network a unique name, fix that first.

share|improve this answer

Windows 7 - manage wireless networks > propietes of selected wifi network > uncheck "Connect when this network is in range"

share|improve this answer
    
Can you expand a bit to make this answer more professional? Include step by step or screen shots so anyone can do it –  Canadian Luke Jun 28 '13 at 20:18

set your own WiFi as 1st choice in your Wifi priority list. Go to Manage wireless networks and select as 1st choice

share|improve this answer
1  
Can you expand a bit to make this answer more professional? Include step by step or screen shots so anyone can do it –  Canadian Luke Jun 28 '13 at 20:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.