Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I bought a new Cisco Linksys WRT54GL router to connect my laptop (running Windows 7) to the internet. I installed Tomato 1.28 firmware on the router.

When I connect the laptop to the router via ethernet cable, everything is fine and I get extremely fast up- and download speeds. When I connect wirelesssly however, websites load extremely slow - it takes dozens of seconds to load a website! <-- This is my question, how can I fix the wireless speed issue?

Gmail for example, is unusable this way. I tried, but this always fails in the upload part of the test so I can't even test the bandwidth (could the fact that it fails in the upload part, not the download part, be an indication what the problem is?!).

I have isolated the problem a bit, I am convinced it has to do either with the router itself, the router settings, or the settings of the wireless connection in Win 7. Because previously, I was using another router by Buffalo and I had no problems whatsoever. I have tried to reproduce the settings from the Bufallo router as closely as possible on the Linksys router (same channel, same encryption etc). The download speed problem only occurs with the Linksys router, and only in wireless mode! When I exchange the Linksys router with the Buffalo router I have here for testing, the wireless speed is up to normal again.

Also, before I had installed the Tomato firmware I had exactly the same problem, so it has nothing to do with the firmware itself.

Notes & things I already tried:

  • Changing the channel: does not seem to affect anything, I am also on the same channel (10) which I was previously on when I had a Buffalo router.

  • QoS is off.

  • Ping to the router itself is OK, ~ 1 ms.

  • Some current settings of the linksys router:

  • WAN / Internet Type: DHCP
  • Wirelesss Mode: Access Point
  • B/G Mode: Mixed
  • Broadcast: check
  • Channel: 10 - 2.457 GHz
  • Security: WPA2 Personal
  • Encryption: AES
share|improve this question
Just curious, if you reboot the router and then run your test right away, does the problem happen right away, or only after the router has been running for a while? – Spiff Jun 8 '12 at 10:59
@Spiff: It happens right away. I have found posts on the internet where people seek help for the problem you are referring to, the problem where the speed degrades over time. This is not the problem I am talking about, I think. The symptoms are different. Do you have any hint/solution regarding my problem? – gojira Jun 8 '12 at 13:49
Have you tried channel 11 (the strongest) ? Does the distance of the wireless client from the router matter : what happens when it is right next to the router ? Have you mapped nearby networks by a tool such as these ? – harrymc Jun 12 '12 at 17:59
@harrymc: yes tried channel 11, too. Distance or antenna arrangement to router does not seem to matter. There are no obstacles between router & laptop. Mapped network with tomato. – gojira Jun 12 '12 at 18:43
You could try the settings on this thread. – harrymc Jun 12 '12 at 20:16

Conduct an environmental scan, you may be getting stomped by a nearby N-router, which gladly can destroy your connection. A neighbor probably upgraded to N since you had the buffalo router.

You are running tomato, so check your power settings. You might have a weak signal and you can test this by moving right next to your router, and then increasing the gain.

Also check the physical condition of your antennas, verifing that they are screwed in well.

share|improve this answer
Somehow I don't think it has anything to do with the signal strength: the router is about 2 meters from the laptop line-of-sight. Also, the ping to the router itself is fast: when I load a tomato page, which is inside the router, I have no lag! The slow download seems only to apply to websites. – gojira Jun 12 '12 at 18:41
Could you check to see if websites will load quickly with the tor browser bundle? If they do, its not the wireless connection itself, but some other thing. – Journeyman Geek Jun 13 '12 at 3:54
I would suggest turning off all security (OPEN) and encryption, switch to 'g' only, and then ping a website. Better yet run a traceroute. Look for packet loss, as you do not have any from the computer to the router. Also from tomato you should be able to run a ping, its being a while... – G Lawlor Jun 15 '12 at 4:45
Oh and also TEMPORARIALY kill your firewall, iptables, and router firewall. You want to troubleshoot with the minimum specs and then add as you go! – G Lawlor Jun 15 '12 at 4:48

I think you have already found the answer yourself : The trouble is with your modem itself.

The WRT54GL is a good router, so either you have bought a lemon, or some parameter went wrong so the best idea would be to reset it to factory defaults.

I suggest to try the WRT54GL at somewhere else than your place - this will tell you whether the problem is with the router's hardware.

If the router works correctly elsewhere but not at your place, it might not fit some strange local conditions.

My guess, as you have tried any and all solutions found on the Internet or suggested here, and especially as another router works flawlessly under the same conditions, is that the problem is with the router's hardware.

share|improve this answer
Sure sounds like faulty equipment/wifi adaptor! RMA it/get it replaced... You may need to reset the firmware to a Linksys one to 'unvoid' the warranty. – HaydnWVN Jun 18 '12 at 11:12
Ha exactly what I said yesterday. Try resetting to factory defaults. – DiscoveryOV Jun 19 '12 at 4:48
@R3TRI8UTI0N: I mentioned it, but I don't really believe that this is the problem. – harrymc Jun 19 '12 at 14:53

Try these

  • disable afterburner and frame burst in advanced wireless settings if they are on

  • switch to channel 4,6,and 8 (you mentioned you tried 11)

  • disable ipv6 within the wireless adapter properties on your windows 7 computer
    speaking of that, try a non-windows computer or hand-held ... is it slow?

  • disable windows 7 tcp auto turning netsh interface tcp set global autotuning=disabled (normal is the default).

share|improve this answer
thanks, great hint with the autotuning I did not try that yet! Will try it. The other points, good hints too, but I tried them already. – gojira Jun 18 '12 at 6:40

You mentioned that Wireless B/G is on mixed mode. Do you have any other devices on the network running on wireless B? This is because if any one device is running on the lower standard, the whole network will jump down to that standard. That said, have you tried connecting to the wireless with devices other than your Windows PC? Try with an iPhone or Android and see if the speeds are any different.

share|improve this answer

Use syslog to view what is happening in the router,and maybe run Netmon or Wireshark to see what is happening from the PC side.

If still stuck, isolate whether the issue is specific to the wireless device i.e. your pc, or the router i.e. for all wireless devices.

If it is specific to your device, isolate whether the problem is interface specific or system specific - connect a different wireless device to the pc with the problem i.e. a usb wireless stick.

If the problem is interface specific, you could also try removing your wireless device drivers, and reinstalling the latest version, preferably direct form the chipset vendor, rather than the system builder. They may also have more options in the driver settings within device manager.

If the problem is system specific, check local computer policy settings relating to firewall and ip - type 'gpedit.msc' from the command window. Computer config > security settings > Window firewall and advanced security.

share|improve this answer

I understand this may be a little weak but if you haven't already, it's worth a try.

You may want to try completely resetting your router to factory settings by locating the small hole in the port area (Normally near power connector) and pushing a small object (paper clip) into the hole until all of the lights on the router shut off. Normally it would say Reset next to it.

share|improve this answer
My answer is a valid solution. It had not yet been written here that the OP had tried it. Please don't downvote my answer for no reason. – DiscoveryOV Jun 18 '12 at 7:03
+1 valid answer - no reason for downvote. – harrymc Jun 18 '12 at 7:31
I feel downvoting is okay. It's clear that we are not at that level of troubleshooting anymore. I would also downvote if someone suggests to check if the power cords are plugged in. – gojira Jun 19 '12 at 10:03

As you say with wired connection the router is working ok and you can reach it with ping with quick response time, configuration looks ok and it seems the router itself is at fault.

I don't think security, wifi parameters or encryption could lead to this kind of overtime. You could try to analyze what channels are in use in your area (maybe they are all used...). There are simple wifi analyzing softwares for android, windows and iphone. Anyways, if you are at 2 meters from the router, your connection should be the strongest.

If you find a channel not used and your connection is still slow on it, I would try to return the router to the store (or an assistance) (or to a friend where you could plug it in maybe) and test it there to see if it's working.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .