Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've noticed that sometimes when we save an image and open it with Adobe Photoshop, the "white" background turns "black".

For example, when I view this image using Chrome, this is what I see:

enter image description here

However, when I saved the file to my computer ("right-click" → "Save image as..") then open the file with Photoshop CS5, this is what I see:

enter image description here

Why does the "white" part of an image turn "black" after saving?

share|improve this question
1  
Has it actually turned "black", or is that just the background colour shown for transparent areas? – Iakovosian Jun 8 '12 at 13:19
    
@lakovosian It turned black. If it was transparent, photoshop would display the "white-gray" checker boxes: screenshoot.me/vLd21c – Pacerier Jun 8 '12 at 13:26
    
I'm not sure why that happened for you in Photoshop, but the original image you linked to definitely has a transparent background. Perhaps there is another underlying problem still to identify? – Iakovosian Jun 8 '12 at 13:27
    
@lakovosian Yes, the point of this post is to identify the underlying problem. – Pacerier Jun 8 '12 at 13:43
1  
@lakovosian When I "erased" the "black" area, it turns "white-gray": screenshoot.me/rx6jQI. So I guess it means that the "black" area was really "black" and not "transparent". – Pacerier Jun 8 '12 at 13:48

It's because it has transparency. And different applications may have different default background colors. In Firefox your picture is shown with a dark gray background.

http://en.wikipedia.org/wiki/Alpha_compositing

share|improve this answer
    
But why is it that instead of showing it as "transparent" (screenshoot.me/vLd21c), photoshop shows it as "black"? – Pacerier Jun 8 '12 at 13:28
    
Perhaps it's a problem with your layer, I don't have Photoshop to make some tests. – Radoo Jun 8 '12 at 13:31
    
Hmm, I didn't edit the layers at all. I directly opened the saved file with Photoshop and it is showing "black" instead of "transparent" (which it should have). – Pacerier Jun 8 '12 at 13:45
    
stop upvoting this answer, it isn't answering the question... – Pacerier Jan 20 '13 at 6:52
    
Yes, it is... (>'-')> mhm... Even Kirby agrees. – Radoo Jan 15 '15 at 21:43

This issue occurs when copying images with transparency. The part you're referring to as white (that turns black) isn't really white, it's transparent.

When you copy a *.png image, what you technically do is save it in your clipboard; but there's a problem: your clipboard is only capable of storing *.bmp images. So the system converts the *.png image to a *.bmp before storing it at your clipboard. Now here's your problem: *.bmp does not support alpha channels (transparency). So what happens to the transparent pixels? they become black.

So the most straightforward solution is to just not use your clipboard (tl;dr): Save the image to a file, and open the file in Photoshop.

share|improve this answer
    
But I did saved the file to my computer and opened it directly with Photoshop as a file. It is still showing "black" instead of "transparent". – Pacerier Jun 8 '12 at 13:37
    
@Pacerier Sounds like the issue is with Photoshop. which version are you running? – MasterMastic Jun 8 '12 at 13:40
    
The version I'm using is CS5 – Pacerier Jun 8 '12 at 13:42
    
@Pacerier Sounds very odd. I've opened it at Photoshop CS6 (which isn't very different) and it opens up perfectly. try to look at the settings etc. maybe the answer is there. I'll try to look up what could be the issue and if I find anything, I'll get back to you. Good luck. – MasterMastic Jun 8 '12 at 13:50
1  
Thanks MasterMastic, your suggestion worked for me. Save to computer and then add to photoshop instead of dragging image from browser into photoshop ;) – Jizbo Jonez Dec 3 '14 at 13:54

Yep - the linked picture definitely has a transparent background. Confirmed with GIMP as shown below.

Transparency with GIMP


As for why your transparent background looks black in PhotoShop may be linked to this:
Chose background colour in PhotoShop <-- Hopefully will lead you in the right direction.
I think you just need to change the Application Background colour back to transparent instead of black.

share|improve this answer
    
That link is only applicable for "creating new images". As I described in the post, I directly saved the file to desktop as a .png file, so I didn't create any new file. In other words, I didn't modify the background in anyway, it should have been still "transparent". Yet photoshop is showing it as "black". – Pacerier Jun 8 '12 at 13:40

From what I understand, it's a matter of the PNG using indexed color for transparency... something Photoshop doesn't like to handle.

More on it at the Graphic Design StackExchange.

share|improve this answer

This issue appears when a PNG is saved with indexed color in CS5 and below.

Photoshop cannot properly display PNG files that have indexed color for transparency because of the way the transparency data is embedded in the alpha palette versus being stored in a separate alpha mask.

The result is Photoshop reading the RGB components of each indexed color and ignoring the the transparency data embedded in the alpha palette of the image. In a normally-saved PNG, this data would be included in a separate alpha mask and be read appropriately by the program. In this case, with the transparency data unable to be read, the image background turns black.

You can read more about this here: Why can't Photoshop properly open this PNG?

Later versions of Photoshop are able to display indexed color PNGs with their intended transparency.

share|improve this answer

I opened my image with "Paint" and then I saved it as a .bmp and it had a message that popped up saying "by saving this image you will lose your transparency". When I saved it, the background turned white!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.