Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to access IIS through web but unable to do so. Basically I have a router (which functions as router and modem) that is given by ISP and I have another router connected to the router given by ISP. My ISP's router can be visited through 192.168.0.1 and the router that I connected to ISP's router can be visited through 192.168.1.1

Please see my ISP's router:

enter image description here

As you can see I have DMZ enabled for my router of 192.168.1.1

Now please see my router of 192.168.1.1:

enter image description here

As you can see I added a virtual server for port 80 where 192.168.1.125 is my private IP.

I rebooted both of my modems an tried to visit my IP from: http://www.whatsmyip.org/

and after doing so, when I type my live IP I still see my router of 192.168.0.1 instead of my IIS. What am I missing?

Note: I have disabled Firewall on both of the routers.

Any help would be appreciated.

EDIT:

When I go to WAN in ASUS I see this:

enter image description here

Does that help?

share|improve this question
    
You are getting your router because 192.168.1.1 is the router and 192.168.0.1 is your UTStarCom modem. You need to forward port 80 to your computers local 192.168.1.125 address. What happens when you vist your public address ( which won't be visible to you within your internal network ). –  Ramhound Jun 8 '12 at 11:40
    
Yup, this should be moved back to Superuser. –  dusan.bajic Jun 8 '12 at 11:40
    
Well, should be closed as a dupe, poster appears to have not liked the fact his first question was migrated (perhaps didn't understand what had happened). –  EightBitTony Jun 8 '12 at 11:44
    
possible duplicate of Why do I see router and not my real IIS? –  Michael Hampton Apr 5 at 4:29
add comment

migrated from serverfault.com Jun 8 '12 at 19:52

This question came from our site for professional system and network administrators.

5 Answers

up vote 2 down vote accepted

Find out what is the IP address of your ASUS router's wan port (should be 192.168.0.xxx). Enter that address in ISP router's DMZ settings.

share|improve this answer
    
You're right. The 192.168.1.1 is the LAN side of the second router. The WAN side must be in the DMZ on the first router for this to work. –  Tonny Jun 8 '12 at 10:44
    
@dusan: ASUS router's IP is 192.168.1.1 and I already have that in my ISP's router as you can see. –  Tim Tom Jun 8 '12 at 10:45
    
@Tonny: How do I find that IP out? –  Tim Tom Jun 8 '12 at 10:46
    
@TimTom: The WAN side of the second router is set to DHCP, right ? First router will show what it has handed out in it's logs. And the Second router will list it probably somewhere in it's status page. –  Tonny Jun 8 '12 at 10:48
    
@Tonny: Please read my question edit. Does that help? –  Tim Tom Jun 8 '12 at 10:49
show 6 more comments

In addition to Dusan's answer above:
Without exact knowledge of the devices in question: In general 2 other issues can come into play in such a configuration:

1) Either or both the routers don't support back-traversal across NAT: Meaning that when you test from the 192.168.. side you can't connect to the outside ip-address at all.

2) The routers own web-interface (also on port 80) is interfering: Try to place that on another port (if possible) and make sure it's not enabled to be accessed from the internet side of things. (That's something that should disabled at all times anyway.) This applies to BOTH routers.

Could be that both cases apply simultaneously. You will have to experiment a bit.

share|improve this answer
    
Can I change router's port? Eg. Can I change it to be on 10000? I don't see any setting in my ISP's router. Can it be possible? –  Tim Tom Jun 8 '12 at 10:59
    
It is very possible that you can't change web interface port. But usually there is setting to "disable web admin access from WAN port" which should suffice. (it can be formulated in many different ways but you should be able to recognize it) –  dusan.bajic Jun 8 '12 at 11:19
add comment

Based on your description, it would appear that the Asus router's WAN interface is hooked up the other router's LAN interface, thus seperating the network, and that both networks operate on their own subnet. The following answer assumes this.

Note that 192.168.1.1 is the address of the Asus's LAN interface and cannot be used outside of this network. If you're addressing the machine from outside, you would use the external IP, perhaps 192.168.0.2. If that doesn't fix the problem, try the following.

On most routers, DMZ works by forwarding packets to a single host if the router does not know what to do with them otherwise. If packets are intended for a different machine, for instance based on a forwarded port or established connection, you would not want the DMZ settings to interfere.

In your case, incoming packets on port 80 may not be forwarded to the router in the DMZ, because something else is taking precedence: the built-in webserver of the outer router. With most other ports, your setup would probably work fine, but in this case, you'll have to forward port 80 manually from the first router to the second, then from the second to the server.

share|improve this answer
    
External IP fixed the problem. Now I can visit my website from hidemyass.com –  Tim Tom Jun 9 '12 at 2:33
add comment

You've pointed the DMZ host to the address of the router, not of the IIS server.

And although you've forwarded port 80 on the other router, I think that port forwarding will only work if it's performing NAT between a public IP address and an internal/private (eg 192.168.x.x) address. Since the Asus router isn't directly connected to the internet, it does not have an external IP and so it probably isn't performing any NAT.

Try setting the DMZ host address to that of the IIS server.

share|improve this answer
    
Doesn't work. If I set DMZ host address to my IIS server (192.168.1.125) then reboot the modem and visit my public IP, I still see router and not my IIS. –  Tim Tom Jun 8 '12 at 11:14
    
It can't work. The Asus router is getting an external IP, in a private range, but is providing NAT nonetheless. Because of NAT, 192.168.1.125 is not accessible from the outer router and cannot be used in the DMZ. –  Marcks Thomas Jun 8 '12 at 11:30
    
@TimTom - You won't be able to vist your public ip behind a router. Just vist your IIS server's internal private address instead. –  Ramhound Jun 8 '12 at 20:00
add comment

You need to forward through both routers, DMZ is not for routing. Instead you could add virtual server/port forwarding from your ISP's router to your server address and then force static route through your own router to your server.

Another way is connecting server straight to your ISP router and simply add port forwarding/virtual server here.

It is also possible to chain port forwarding...

Also remember that if you are behind your own routers while testing with external ip your own traffic still comes from LAN side, not from WAN. It may affect routing, use traceroute to see how it is routed currently.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.