Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I tried to install ADB through the terminal on Ubuntu, it told me "permission denied":

~/android-sdks/tools/ $ ./android
bash: ./android: Permission denied
~/android-sdks/platform-tools/ $ ./adb devices
bash: ./adb: Permission denied

Can anyone help me with this?

share|improve this question

Make sure the android file (and others) are executable.

If you run chmod +x android, that should set the executable permission, which would allow you to run the binary.

To do this for all files in tools or platform tools, simply run:

chmod +x ~/android-sdks/tools/*
chmod +x ~/android-sdks/platform-tools/*
share|improve this answer

check if the commands are exacutable:

ls -l adb
-rw-r--r-- 1 tsi tsi 0 Aug  5 11:58 adb

my user is "tsi", and I don't have e'X'ecute permissions on it, now make it executable:

chmod +x adb
ls -l adb
-rwxr-xr-x 1 tsi tsi 0 Aug  5 11:58 adb

Now it should be ok.

What else could prevent to make it executable?

  • the files are not on a linux filesystem
  • they are on a linux filesystem, but it is mounted without execution permissions
share|improve this answer

same problem happened for me

open the terminal and check whether adb server properly installed by the using the command

adb version

if not installed error shows then type the following command t install after that everything worked fine for me.

The program 'adb' is currently not installed. You can install it by typing:

sudo apt-get install android-tools-adb
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.