Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows 7 computer with Firefox and Chrome on my WiFi network. Chrome is slow. I open a new tab and then enter a url and it takes > 10 sec before the page starts to load. In Firefox, no delays. However, once the page does start to load, it loads at the same normal, fast, speed in both browsers.

Any suggestions?

I have no Chrome plugins or anything like that, I tried emptying my history, cookies, etc.

share|improve this question
    
Google Chrome demands a lot of resources, and so you need a decent PC (decent meaning better than intel P4 and 2GB RAM) for decent user experience. Chrome is slow for me because i have a slooow PC –  Sylvester the Cat Nov 1 '12 at 1:11

5 Answers 5

up vote 5 down vote accepted

Try adding --in-process-plugins to the command line.

share|improve this answer
1  
This would be worth a shot. You have plugins running whether you realize it or not, i.e. Flash, Silverlight, etc. –  Will Eddins Sep 18 '09 at 18:04
    
@Linus: How do I do this... >_< ? –  rlb.usa Sep 18 '09 at 19:03
    
@rib.usa blogsdna.com/1900/… –  Linus Sep 18 '09 at 19:12

Under Options > Under the Hood try disabling Use DNS pre-fetchign to improve page load performance. That was causing all sorts of problems for me including slow page loads or inability to connect to a server.

share|improve this answer

Two solutions:

  1. Use Chrome in Windows 7 Pro's Virtual XP mode.

  2. Run Chrome as administrator: Right-click the Chrome icon » Properties » Compatibility » Privileges

share|improve this answer

Instead of making plugins inline, you can also set things up so plugins don't run until you click on them. Like no-flash for all plugins.

The option is at Settings > Advanced Settings > Content Settings Plug-ins > Click to play. More info here - Description is here http://www.webmonkey.com/2010/11/chrome-now-offers-click-to-play-option-for-flash-other-plugins/.

share|improve this answer

This problem drove me crazy for a few months (FWIW: Windows 8, 64b). I would type all my search terms or web address without seeing them appear, then waited sometimes up to half a minute before the words would show and the search/navigation would take place. I had switched off all the settings in Chrome that I thought could be responsible, cleared caches, read all the fora, but the omnibox was sluggish.

Eventually found out I needed to switch off "Predict network actions to improve page load performance" under advanced settings.

Now the search bar reacts immediately, just as it should!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.