Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two computers connected to a network switch and every once in a while one of the computers will lose its internet connection. It's almost always the same computer every time. However, if I play around with the control panel, I can switch it, so that now the other computer is not connected. Restarting either of the computers does not help either. In Windows, the worlds-greatest-trouble-shooter tells me that a network cable is unplugged and that I should try plugging it in...Disabling and re-enabling my NIC does not fix this problem, neither does swapping cables around. When rebooting, the BIOS complains about how the Ethernet Cable is not plugged in.

If it's in any way important, My set up at the office is like so:

Modem -> Routher -> Network Switch 1 -> Network Switch 2.

I have tried turning off the energy saving option for my NIC, and I tried manually setting the link-speed to 100Mbps Full Duplex without any luck.

Also, I have a Realtek PCIe GBE Family controller on both computers

Does anyone have any idea why this is happening every 5-10 days?

EDIT: I have also tried using a completely different Network Switch and the problem still persists as before.

EDIT: here isthe output file for ipconfig for the connected computer. The other one is completely blank

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . : vn.shawcable.net
   Link-local IPv6 Address . . . . . : fe80::1c4b:a81e:8ca1:de6a%11
   IPv4 Address. . . . . . . . . . . : 192.168.1.103
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : 192.168.1.1

Tunnel adapter Local Area Connection* 9:

   Connection-specific DNS Suffix  . : 
   IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:109d:2e21:cdbb:f335
   Link-local IPv6 Address . . . . . : fe80::109d:2e21:cdbb:f335%10
   Default Gateway . . . . . . . . . : ::

Tunnel adapter isatap.vn.shawcable.net:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : vn.shawcable.net

Tunnel adapter 6TO4 Adapter:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 
share|improve this question
    
Why do you need two switches? What is the ipconfig readout on both computers? –  MaQleod Jun 9 '12 at 1:33
    
Are the lights still lit on the NIC and the switch when it does this? Also, sometimes a driver reinstall can fix mysterious problems. –  Adam Jun 9 '12 at 3:35
    
@MaQleod Sorry, my internet completely went down. i will put the ipconfig info in for you –  puk Jun 9 '12 at 5:17
    
@Adam The lights on the NIC for the connected Computer are on, they are off for the disconnected computer, and there are 3 lights on on the switch (two for computers, 1 for internet) –  puk Jun 9 '12 at 5:19
add comment

1 Answer

It may be duplicate IP addresses assigned to both computers. To manually select an IP address, go to

Control Panel -> Network and Internet -> Network and Sharing Center -> Change Adapter Settings (Located on left panel) -> Find your ethernet adapter, right click, and select properties -> Find 'Internet Protocol Version 4(TCP\IPv4) and select properties -> Use the Following IP Address, and enter an IP address

Typically an IP address for most networks will be something like 192.168.1.20 Set the subnet mask to 255.555.555.0

Repeat for both computers, making sure the IP address for both is different. (If you how how to do that via your router, that would be even better. But because each router is different I gave directions for assigning a static IP via Windows)

The reason that happens every 5-10 days (Prob. 8 days) is the IP lease expires every 8 days or so and the IP is re-assigned at the end of that period.

share|improve this answer
    
I suspected this was happening, and I just gained access to my router today. I am trying this out. If it works, I won't be able to select your answer for a few weeks, just to be safe –  puk Jun 9 '12 at 5:23
    
Fantastic. The Linksys WRT54G2 doesn't support static ip's via the DHCP server. I'll have to use your solution. –  puk Jun 9 '12 at 5:33
1  
I'd recommend setting the IP address high to reduce the chance of DHCP assigning the same IP to a diff. computers. (ie 192.168.1.200) –  Usta Jun 9 '12 at 6:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.