Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Windows doesn't want any USB devices since last reboot, but Arch sees them.

My laptop (Asus N75SL, almost new) has decided that on windows it did not want to register USB devices. Since the machine dual boots Archlinux (for work purposes) I checked whith him and it registers the Apple keyboard and the gaming mouse no problem. I tried other devices besides mouse and keyboard such as USB headset and DAC.

To be noted that the said devices were registering fine one week before and the keyboard and headset were registering last reboot. The last software to be installed was the RC for Visual Studio 2012 and the update for windows defender.

I'm currently uninstalling VS2012 (to be sure). But I have doubts since it didn't break any other PCs I tried it on.

share|improve this question
When you open up Device Manager, any Yellow Exclamation points standing out? Anything in the Event Log as far as errors go? – Bon Gart Jun 9 '12 at 15:07
The todays error are: ESENT Can't open log file and CAPI2 can't init because of ESENT failing (This was during VS2012 uninstall) – Jeremy David Jun 9 '12 at 15:29
Nope, Just not picking up that the devices are plugged in. – Jeremy David Jun 9 '12 at 15:32
The USB3 on Asus laptops are not well supported. Try to reconnect to different side of laptop, some of USB ports are still USB2 kind. And to resolve completely, load the drivers from Asus web site. – user27803 Jun 9 '12 at 15:34
@"Rocket Surgeon" Well it was working fine until today – Jeremy David Jun 9 '12 at 15:35

Check your Windows root certificates. MS may have security patches or updates for the standard root certificates that are installed in Windows. These are needed to install signed drivers, including drivers for HIDs.

I had a Windows XP machine once that would no longer accept a USB keyboard or mouse, and this was the issue. For some reason, the certificates were gone or never updated, thus expired.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .