Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I set up framerelay and I can successfully ping from R1 to R2. The problem I'm having is that there aren't OSPF advertisements. I explicitly stated broadcast when mapping the IP's. Here are my configs:

R1:

interface Serial0/0
 ip address 10.10.10.1 255.255.255.252
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 0
 no keepalive
 serial restart-delay 0
 clock rate 64000
 frame-relay map ip 10.10.10.2 201 broadcast

router ospf 1
 log-adjacency-changes
 network 10.10.10.0 0.0.0.3 area 0

R2:

interface Loopback0
 ip address 10.12.0.1 255.255.255.0

interface Serial0/0
 ip address 10.10.10.2 255.255.255.252
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 0
 no keepalive
 serial restart-delay 0
 frame-relay map ip 10.10.10.1 201 broadcast

router ospf 1
 log-adjacency-changes
 network 10.10.10.0 0.0.0.3 area 0
 network 10.12.0.0 0.0.0.255 area 0

When I ask for routing info:

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.0 is directly connected, Serial0/0

I do not understand why it doesn't work. I'm using GNS3.

share|improve this question
1  
Can you capture traffic to make sure OSPF's neighbor advertisements are making it across the link, and check the output of show ip ospf interface Serial0/0? Might be able to get it going like this, but it looks like Cisco's recommended config over a frame relay is to use subinterfaces. –  Shane Madden Jun 10 '12 at 17:47
    
aah nice, add it to an answer and I shall reward you a V –  Lucas Kauffman Jun 10 '12 at 20:39
    
Indeed you need to use subinterfaces to be able to send broadcasts and to avoid routing loops at the same time –  MrLightBulp Dec 13 '12 at 19:58

protected by Journeyman Geek Dec 25 at 11:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.