Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've had a fair bit problems with sometimes files/folders/processes being 'locked' by Windows.

The weird thing is, it's not like the traditional sense, I think, where tools like UnlockIT and wholockme would work. It seems that just giving it a little often helps - making me think it could either be the HDD, the memory, or something in Windows.

A scenario:

I go into a folder - don't open anything at all, go back up, cut or drag-move the folder to someplace else, it says "Action can't be completed because the folder or a file in it is open in another program".

Waiting sometimes 20 seconds sometimes a little longer, and I can move it.

Another scenario is deleting a bunch of files in a folder, and it appears that everything is gone, but then suddenly after a few seconds an .exe file pops back up, and I can't delete it. Waiting a few minutes, then pressing refresh and it's gone.

I have the strangest feeling that there's a problem with either HDD or memory.

I already tried disabling Windows indexing service with no luck.

Does anyone have any ideas?

I should say, that I have a very fast system, 16 GB DDR3 RAM, i7-2600k CPU, SSD main HDD, so I really should not be experiencing any sort of problems, where one might say that it's "reasonable" for the system not to respond right away.

And I updated SSD firmware a couple months ago, so it shouldn't be bad release FW either

share|improve this question
    
What antivirus are you using? –  user3463 Jun 10 '12 at 20:16
    
I'm not running any antivirus, I run windows defender once in a while for malware (none) and being a software developer, I know how to at the very least take care not to fill my pc with crap/obvious virus. I could run a Windows Antivirus check, but I'm almost positive it won't find anything. –  Dynde Jun 10 '12 at 20:18
    
That's got nothing to do with my question. Most antiviruses (Defender included) will lock files temporarily when scanning them, which could be related to your problem. –  user3463 Jun 10 '12 at 20:23
    
Yeah, after I replied, I figured that's what you meant, anyway, defender is disabled. the only piece of active protection I have is windows firewall. I only run defender once in a while for scans. –  Dynde Jun 10 '12 at 20:35
    
Unlocker will show you what is locking your files (in addition to offering to remove the lock) –  soandos Jun 10 '12 at 21:24
show 1 more comment

1 Answer

up vote 0 down vote accepted

I found out that it was System (PID 4) which locked the files/folders. Following solutions from this and this I tried re-enabling Application Experience, which seems to have solved the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.