Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

An issue that has been bothering me for over a year now. My notebook, running ubuntu 10.04, is almost all the time using a wired connection, with static IP address. And a remote DNS server. Network is configured with entries in /etc/network/interfaces and /etc/resolv.conf, rather than whatever the gnome UI tool was (*)

But if I'm out, or simply unplug the network cable, a few things get weird. Specifically the gnome-panel stops working - it is still there, but isn't updating. And opening a nautilus window (e.g. to look at files on the local disk) has huge time-outs. By that I mean it will not open the window for something like 30 or 60 seconds; but when it does finally open it I can see the files and it is perfectly usable.

Everything else works fine, alt-tab between windows, etc. I use the commandline to find the pid of gnome-panel, kill it, wait a couple of seconds, and it opens up a fresh panel which is normally usable.

(Something like 10 minutes later it will have locked/crashed again; the same for the nautilus windows.)

I'm guessing this is a DNS issue? Would setting up a local DNS server help? [No, see UPDATE#2 below] Guess number 2 was related to having a file server mount (samba, though running on another linux box), and symbolic links to files and directories on that file server on my desktop.

My question is a bit vague... Does anyone recognize these symptoms, and have a suggestion? Or do you have some troubleshooting suggestions for narrowing down the problem?

I mount my samba drive with an entry in /etc/rc.local:

mount -t cifs -o "user=guest,rw,iocharset=utf8,nounix,uid=darren,gid=darren,dir_mode=0775,file_mode=0664" //10.0.1.99/xxx /mnt/xxx

(This approach has worked well for the almost-always-have-a-wired-connection setup I have.)

My /etc/hosts:

127.0.0.1   localhost
127.0.1.1   myhost

# The following lines are desirable for IPv6 capable hosts
::1     localhost ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

127.0.0.1      testsite.local

#Other test website URLs here

UPDATE: Some timings to open some desktop folder icons. This is after pulling out the network cable. A sub-directory of the desktop took 23 secs to open up. Content appears immediately (just 8 files, it has no further subdirectories). The home directory icon took 12 seconds to open up, but then took about 30 seconds for the files to appear. I closed it and tried again. This time it took 18 seconds to open up, but then 70 seconds before anything appeared.

UPDATE #2: I tested the DNS server by installing bind9 package. It seems to come ready configured as a cache-only DNS server, so all I did was add 127.0.0.1 to the top of /etc/resolv.conf. (I also added my previous DNS server in the forwarders section of /etc/bind/named.conf.options.) It did not help. But I was tail-ing syslog, and this is what I saw when clicking the home icon on my desktop, after removing the network cable:

Jun 12 09:06:54 myhost kernel: [479308.182192]  CIFS VFS: Unexpected lookup error -112
Jun 12 09:07:04 myhost kernel: [479318.179143]  CIFS VFS: Unexpected lookup error -112
Jun 12 09:07:14 myhost kernel: [479328.186138]  CIFS VFS: Unexpected lookup error -112
Jun 12 09:07:24 myhost kernel: [479338.900497]  CIFS VFS: Unexpected lookup error -112
Jun 12 09:07:34 myhost kernel: [479348.897468]  CIFS VFS: Unexpected lookup error -112
Jun 12 09:07:44 myhost kernel: [479358.894431]  CIFS VFS: Unexpected lookup error -112
Jun 12 09:07:54 myhost kernel: [479368.891429]  CIFS VFS: Unexpected lookup error -112

(I double-clicked at 09:06:49, so the first complaint was at 5 seconds. The window appeared at the 20 second point, but the contents of the window did not until 09:07:54. Then syslog went quiet again.)


*: I couldn't work out how to use the gnome network tool for my needs, which include 3-4 static IPs for testing virtual hosts locally.

share|improve this question
    
What is in your /etc/hosts file? Do you have a line like 127.0.0.1 <your machine name> localhost? –  Renan Jun 11 '12 at 1:39
    
@Renan I've pasted it in above. I don't have both machine host and localhost in a single line; should I?. I notice the myhost line is '127.0.1.1', not '127.0.0.1'. I can't tell you if that was deliberate or a typo. Does it matter I wonder? –  Darren Cook Jun 11 '12 at 3:22
    
@Renan I changed 127.0.1.1 to 127.0.0.1, and it made no difference. (but they are still on separate lines). –  Darren Cook Jun 11 '12 at 3:39
    
CIFS VFS: Unexpected lookup error -112. Do you have any Samba/CIFS shares mounted (i.e. accessing shared directories on a Windows machine)? –  Renan Jun 12 '12 at 0:29
    
@Renan Yes (and as mentioned in the question, I have symbolic links to that mounted drive, e.g. in my home directory and on my desktop). I've just updated the question again, showing how I do the mount. –  Darren Cook Jun 12 '12 at 0:33
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.