Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Asus laptop, and when it boots up (but before the bootloader) it makes a sound.

When I have headphones plugged into the jack, and I had shut down from ubuntu, the sound goes to the headphones. If I had just shut down from windows, the sound goes to the speakers.

What gives? If possible, I would like the sound to always go to the headphones.

share|improve this question
    
What kind of sound, a beep? Have you tried looking in your BIOS settings for an option to disable the sound? – iglvzx Jun 11 '12 at 4:54
    
Its a boom I guess you can call it. It is not a beep code or anything like that. As far as I can tell, there is nothing in the BIOS settings that deal with it. – soandos Jun 11 '12 at 5:02
up vote 1 down vote accepted

You will need to modify the Windows driver for the sound card to inhibit resetting the audio hardware before unloading.

share|improve this answer
    
I think you misunderstand. I like the way that linux does it, and I want to make windows behave in the same manner. – soandos Jun 11 '12 at 5:24
    
Oh, whoops. Well, the solution is still mostly the same. – Ignacio Vazquez-Abrams Jun 11 '12 at 5:30
    
How would I do that? – soandos Jun 11 '12 at 5:32
    
The problem now is that you can't. You'll need to talk to whoever wrote the driver. – Ignacio Vazquez-Abrams Jun 11 '12 at 5:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .