Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The problem is described well here, so I won't repeat it; but basically, hiding the Silverlight update the naive way doesn't work.

So the question is -- how do I tell Windows to shut up about Silverlight and stop bringing it up on the list?

share|improve this question
    
explain "it's not installed". What's not installed? Microsoft Office? He was simply giving you an example of another Microsoft Product that you would ALSO not get update notifications about, if you follow that recommended solution. So, you disable the update notifications for Microsoft products (not Windows) and you don't get update notifications for Silverlight or any other Microsoft product. –  Bon Gart Jun 11 '12 at 11:52
1  
You may think that the same "update" appears over and over again, but it's not. I just installed a new system. As I don't need Silverlight (or more precisely the Silverlight plugin for my webbrowsers) I chose to hide the "update" (which is actually not an update as Silverlight is not installed). When I click "Check for updates" again, the same Silverlight "update" seems to appear again, except it's not the same: it has a different ID. After hiding and checking for new updates several times, Silverlight doesn't appear anymore. The next time a new version will be out, it will reappear though. –  user276648 Mar 14 '13 at 6:50
2  
its freaking annoying, I've repeatly for the last 3 days selected "hide this update" and it keeps popping up each day. –  BerggreenDK Apr 30 '13 at 7:54

5 Answers 5

I recently had this issue also, after installing a Windows 7 VM for work. Having not used Windows for quite some time this was very annoying to me as well.

I had a clean installation of Windows 7, upgraded to whatever the latest service pack is as of this writing and I'd refused to install Silverlight. However, it appears that Windows 7's service packs now "preload" portions of Silverlight, making it show up in Windows Update even when not technically fully installed. Highly irritating.

To fix this issue, I followed the removal directions in the following article from Microsoft's Support website: How to clean a corrupted Silverlight installation and then reinstall Silverlight.

After doing the complete removal from the "Let me fix it myself" section, Silverlight has not once showed up in my Windows Update.

share|improve this answer
2  
so you installed the plugin after all? the idea here is to GET RIDE of the plugin and keep it from popping up in Windows update. –  BerggreenDK Apr 30 '13 at 7:58
3  
No, I removed the plugin. As I said in my answer I only followed the removal instructions. The instructions just happened to be in a Microsoft article about reinstallation, the second half of which you can ignore. –  Bryson Apr 30 '13 at 20:07
    
Like @Ohto below - I tried this (ran all the deletes in a batch file), but WU kept moaning until I hid every update as he suggested. Maybe I missed something? EDIT: I wonder if clearing the WU Download directory (%windir%\SoftwareDistribution\Download) would have negated the need for hiding? –  Umber Ferrule Apr 4 at 9:49
    
I had to attempt this like 4 or 5 times last time I reinstalled my Windows 7 VM in VMWare Fusion. It eventually worked, but they're changing things apparently. Not sure what or why. –  Bryson Apr 6 at 0:25

The issue became clear to me when I hid Bing Desktop v1.3 and Bing Desktop 1.2 showed up next. Upon careful inspection I had noticed that the Silverlight updates are each with a different date.

So lets say there are 10 Silverlight versions released. V10 will obsolete v1 through v9 and only v10 will show up. Choosing to hide v10 will cause v9 to show up, hiding v9 will show v8 the next time you check for updates, and so on and so forth.

If you are persistent about it you can hide every single version of Silverlight and it stops showing up (until the next version is released by MS).

share|improve this answer

If the fixit solution doesn't work (like it did not for me), here is a bit more detailed solution.

  1. Click right mouse button on it, select Hide.
  2. Press ALT + Up or the up arrow next to the address bar
  3. If there is again a Silverlight update available, repeat steps 1. and 2.
share|improve this answer

Enter Regedit and look for the following path:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Silverlight

In there, there will be a key named "UpdateConsentMode", whose value is set at 1 at installation. Changing it to 0 will disable the reminder.

share|improve this answer
    
That key doesn't exist on my system. I assume it's only created once you already installed Silverlight, but in this case we don't want to install it at all. –  André Daniel Sep 18 at 16:09

Try disabling Microsoft Updates in settings.

But the side effect is you will not get important updates for other products like Office.

.

enter image description here

share|improve this answer
11  
This is a terrible non-solution. The issue is not that he does not like Windows Update updates, it's that Windows Update continues showing him an "optional" update for Silverlight which he hasn't installed. Disabling Windows Update completely may be the worst security advice you can give any Windows user, for any reason. –  Bryson Apr 8 '13 at 20:39
1  
Indeed terrible, you dont disable windows update, thats crazy - you only need to remove 1 single item you dont want installed on your computer. Its like, okay - I dont like the amount of gas my car uses, so remove the engine. –  BerggreenDK Apr 30 '13 at 7:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.