Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

One of the most annoying things that happen to me is when I work in a window, typically an editor, or a console, and some application suddenly starts and covers the currently active window... Is there a way to prevent this from happening? The environment is KDE 4.8 on Fedora 17. Windows actually behaves exactly as described above - new windows never pop-up above the currently active window, unless they belong to the same application and are dialogs.

However, if there is no activity in the active window, it would actually be helpful if the new window "takes-over". :)

Edit 1: I am looking for a general (preference) solution, if available. I am aware of the fact that I can modify window to be on top of everything.

share|improve this question
add comment

3 Answers

Go to System Settings, and click through as follows:

System Settings
  \
  (section Workspace Appearance and Behavior)
   Window Behavior
     \
      (on left) Window Behavior (again)
        \
         (on top: Tab) Focus

Set "Focus Stealing Prevention Level" to "None".

For me this was set to "Low", and all new windows that already had started a window of the same type (e.g. Konsole, Firefox, gVim) would appear behind the active window. Setting to "None" resolved it.

This used to be working, for months even, but suddenly changed behavior a few days ago. I'm on a managed corporate Linux workstation, so this could have been a settings rollout by I.T., no idea. After changing that setting, new windows appear on top.

share|improve this answer
add comment

KDE... the desktop environment. As in... The KDE version of Linux Mint? Kbuntu? KDE Debian?

You probably have the option already there. So, right click on the title bar of the Widow you want to keep on top, and see if there is the option there "Always on Top". That won't handle the activity detection, however. I don't know of any program that will keep a window on top while it is active, but after some period of time allow it to go to the background.

Now, you could always install wmctrl and use the following command, if you don't have the option at the title bar.

wmctrl -r windowname -b add,above

Grab it from here.

share|improve this answer
    
Bon, my OP is not concise enough. I modified it. See the Edit 1. Thanks for reply anyway, I appreciate it. –  DejanLekic Jun 11 '12 at 15:56
add comment

Run kcmshell4 kwinoptions and increase Focus stealing prevention level.

For obstinate programs, run kcmshell4 kwinrules and create a rule that puts new windows from that app in the background or starts minimised. This rules interface is also available from the context menu of each window's menu bar.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.