Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When you connect to a new wireless network in Windows 7 there's a popup where you identify the network as either Home, Work or Public. The wireless network remains with a yellow warning mark until you choose one of the 3 options. In my DELL laptop this popup usually takes many minutes to appear and sometimes I have to reset the wireless NIC (via troubleshooting process usually) to force it to popup.

Is there a way to make this window pop up manually?

share|improve this question
up vote 4 down vote accepted

Well for a Windows system, the network location is an important aspect of network security, as windows manages different levels of security and firewall settings for different network locations.

Whenever you setup a new connection it is asked to choose proper network location, but if you want to select network location manually:

Go to Control Panel > Network and Internet > Network and Sharing Center

You will see this type of window:

enter image description here

As you see, click on the link named Public Network just below Broadband Connection (may be your connection name be different).

It will open the desired dialog box for you:

enter image description here

P.S.: you can check the box saying Treat all future... to set all network location at once, it will not disturb you again.

share|improve this answer

You can set or change this from the "Network and Sharing Center" in the Control Panel (listed as "View network status and tasks" if you are in category view). Once there, click the network type under your active networks and it should show the popup you are looking for.

share|improve this answer

There is indeed. If you navigate to Network and Sharing Center, underneath View your active Networks, the wireless network you have just connected to will appear there most likely as an Unidentified network, click on the Home/Public/Work link underneath the network name, and it will allow you to choose from the above options.

You can also check that option at the bottom of the screenshot which will automatically treat all connections as say Public by default - then you can go and manually change it for your needs in Network and Sharing Center - but at least it will connect straight through.

Hope this helps.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.