Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Windows 7

I wish to manually lock the computer so I placed a shortcut to scrnsave.exe on the desktop. (I do not want the user to use Ctrl+Alt+Del --> Lock This Computer for various reasons)

Problem is that when double-clicked, the screen saver starts but it's not password protected.

However, in Personalization --> Screen Saver, that same screen saver is the selected one and it IS configured to display logon screen upon resume. And that works when Windows starts the screen saver.

So how can I cause "On resume, display logon screen" behavior by manually starting a screen saver? (Scripting is an option if I know what to do.)

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

You can create a desktop shortcut for Lock Workstation, it's C:\Windows\System32\rundll32.exe user32.dll, LockWorkStation on the target path. Then, install MonitorES to automatically turn off the monitor the moment it's locked. Ok, it's not starting the screensaver, but it save more energy, and I think the screensaver thing was more about "click to lock"

Edit : A setting in MonitorES also allows auto starting of screensaver when locked, and it will work when you set a screensaver on Display setting. Still, I think it's better to simply turn off the monitor.

share|improve this answer
    
this is a better solution. –  tumchaaditya Jun 12 '12 at 4:38
    
I agree. This is closer to what I was asking. Thank you all. –  gibberish Jun 12 '12 at 20:58
add comment

Cannot you use the key combination of Window Key + L?
It will lock your screen and the tasks will not be affected.

Some other useful Keyboard Shortcuts.

Update:
Well here is your screensaver solution:

As I said and you checked, the setting for display logon screen will only be in effect after the time set as default "Wait" for the screensaver passed by. Otherwise the custom screensaver (open by double-click) will result in back to desktop rather than logon screen.

enter image description here

Cheers! :)

share|improve this answer
    
Thanks Asif. Forgot about that one. I'll see if that is acceptable - users like to click an icon on their desktop rather than remembering a keystroke. I am still curious about the screensaver solution, though. –  gibberish Jun 11 '12 at 21:21
1  
@gibberish see the update..hope you'll got what you wish for..:) –  Asif Jun 11 '12 at 21:26
    
Hi Asif, I saw that (see para3 of my original question). Interestingly, that setting seems to be ignored if screensaver started by double-clicking shortcut the scr file. –  gibberish Jun 11 '12 at 21:30
1  
Oops I got a pinch :) .. and Yes offcourse the default setting for logon screen will be with the default screensaver popup. you can reduce the screensaver popup time if you use it more oftentimes. –  Asif Jun 11 '12 at 21:34
    
I just tried that and you are right: double-clicking the shortcut opens the screensaver right away, but it doesn't become password protected until the "Wait" period specified in the screen saver dialog has expired. Please enter this as a separate answer and I'll credit you with the solution. –  gibberish Jun 11 '12 at 21:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.