Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've found that, although my laptop CPU temperature is usually 50-65C, whenever I keep running flash applications on any of my two browsers (chrome, firefox) it gradually keeps rising, to the point of about twice a day getting my screen to hang.

I've got all the latest drivers, cleaned dust bunnies from the fans, and am planning to have the thermal paste re-applied to the fan in about a week.

But my question is, is there a way to keep flash from using so much CPU in general, while still browsing flash-based webpages (ie. not flashblock)? It's the only adobe product I can't help but have in my pc and it's getting more bloated with each update..

share|improve this question
So complain to Adobe after each update and tell your friends to do the same. And I'm not joking. – geek Dec 14 '09 at 6:08
up vote 6 down vote accepted

Heating is caused by intensive CPU work, and if your laptop is prone to heating then Flash isn't the only problem that you will encounter in the near future. There are several solutions that are quick and almost costless.

The article Laptop cooler from wikipedia is very short but contains some interesting pointers. It makes the remark:

Studies conducted by California Polytechnic University show that heat build-up in notebooks is reduced by 15 to 20 percent, when a laptop is situated at an angle compared to a laptop in a horizontal position. Free air cooling which is a passive method and requires no additional power has been proven as an effective method of laptop cooling.

The following contain some good ideas:

Guide to Cooling Down Your Notebook Computer
Laptop Stands with Cooling Fans
Cool Your Laptop with 99-Cent Cooling Balls

share|improve this answer
Although I was looking for something flash-specific, your links are really informative. thanks :) – surfmadpig Sep 18 '09 at 23:27
I think the point is that Flash is just pounding the CPU, in ways that other programs do not. – benc Dec 14 '09 at 6:10

This is a problem with the latest few versions of Flash and I have written about it in many questions.

Your best bet is to use AdBlockPlus in Firefox.

I have no idea what causes this bug as I have created a few full Flash intensive websites and the CPU doesn't break a sweat, where as I can go on to Hotmail and see a tiny flash advert for some company and the CPU (well, the core) goes to 100%.

AdBlockPlus does a very good job at blocking all adverts and I have only run in to a single site where it blocked legitimate content, however all it took was a single click to show the page.

I would highly recommend it and I have not had a problem with high CPU since installing it.

share|improve this answer
yep, I do use adblockplus, but I use flash to view all other sorts of things, such as (ok, this is embarrassing) facebook games and youtube. in fact, adblock is the biggest reason I haven't migrated to chrome :) – surfmadpig Sep 18 '09 at 20:45
Do you allow all of Facebook? I am on it alot but leave AdblockPlus on and I do not notice high CPU :S – William Hilsum Sep 18 '09 at 20:57
nah, i just allow two specific flash games. but they're both very heavy. – surfmadpig Sep 18 '09 at 20:59

I know that this does not solve your problem, but maybe it can help you.

There is another good add-on that I use a lot, and it is flashblock. That add-on stop all flash from loading, and instead you get a "play"-button where the flash-thing was.

share|improve this answer

You can also use the two-browser approach.

Firefox lets you disable plugins, so you could run Firefox as your primary browser, then use another browser (Safari, IE, whatever) as the flash-enabled browser.

For Mac, you could use a Camino as your primary browser, because it has integrated flash-blocking. That's what I do.

share|improve this answer

First of all, clean your notebook thoroughly. The buildup of dust and grime inside can prevent the cooling from being effective (think of it as your machine wearing a thick winter coat in the scorching summer heat).

If that is not enough, consider limiting your processor frequency. It is dependent on the make and model, but if you look in the BIOS you will often find some some entries that have an effect on processor frequency. This is a trade-off. You trade speed for reliability.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .