Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a fairly straight forward .tmux.conf file which does nothing more but to define a couple of options, such as history-limit. I have not added any custom key bindings yet.

I find it extremely annoying that I cannot unbind C-[ as a prefix in tmux. Here is what I mean:

$ uname -a
Linux stan-inspiron 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

$ tmux
[0] 0:~*         "stan-inspiron" 10:05 12-Jun-12

  % vim

Whilst inside vim, when I go to insert mode and then use C-[0 to escape insert mode and move to the first character on the line, tmux grabs the key first and complains:

Window not found: :0 **

I tried all sorts of things in my .tmux.conf, but nothing works. I thought it might be a terminal or shell issue, but confirmed same behaviour on a configless machine using Bash and [Gnome] Terminal.

So the question really is, how do I unbind the C-[ key from tmux?

** I have base-index 1 set.

share|improve this question

I've checked the tmux man page and C-[ is not even bound. The default prefix is C-b and [ is just a command key.

Are you sure that C-[ enters copy mode?

share|improve this answer
    
It doesn't enter copy mode (which is prefix, [). It acts like a prefix key (usually C-a or C-b), e.g., C-[0 attempts to move to window. – StanAngeloff Jun 12 '12 at 10:15

I've just finished my .tmux.conf file and the issue is gone. I can't say which option turned it off, but I am glad it's gone for good. Thank you all for reading/participating.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .