Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I updated my Fedora 16 installation to Fedora 17 on Saturday, and the update worked without reporting any errors. I carried on working on the machine in question and then switched the computer off.

Last night I went back on the computer, I switched it on and got to the log in screen. At this point I tried to type in my password but the keyboard wouldn't work. I unplugged it (it's a PS/2 keyboard) and plugged it back in. The lights flashed for a split second but the keyboard still wouldn't work. I then plugged the keybaord in to a USB to PS/2 adapter, and the keyboard still wouldn't work.

I restarted the computer and tried to access the BIOS and I was able to do so. So the keyboard doesn't seem to be faulty, it just doesn't work when Fedora boots in to the GUI interface.

I did try to boot in to the "recovery mode" of Fedora, and the keyboard works here with no problem.

As I still have access to Fedora via a terminal interface, is there anything I can do to fix the keyboard problem via the terminal without having to reinstall Fedora?

share|improve this question

I have had a similar problem. In a terminal try:

sudo system-config-keyboard

Choose you keyboard language. That made it correct for me. The only problem I seem to have is that if I reboot, it get reset again.

share|improve this answer
    
I've tried this and it didn't work. I've ended up getting the Fedora 17 disc and replacing the current OS with this. Thanks anyway! – mickburkejnr Jun 18 '12 at 8:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .