Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

my grandpa is running Pclos 2012 KDE4 on his desktop and uses Claws-mail. However (maybe after last update) claws-mail suddenly dies after almost very action like forward, reply etc. without any error message. I tried to run it from Konsole and after clicking on Reply button in Claws it crashed. Konsole showed me this:

[dedecek@localhost ~]$ claws-mail
claws-mail: symbol lookup error: claws-mail: undefined symbol: g_mutex_new
[dedecek@localhost ~]$

Checked Ksysguard for possible zombies etc. but there seems to be all ok. The only strange thing was, that I was not able to reinstall Claws via Synaptic - it remain in "preparing installation" phase and I closed it then. I reinstalled using apt-get via Konsole - successfully, but problem still remains.

Any ideas, where could be problem?

thanks

share|improve this question
    
Can't really help you, but just wanted to note that I've been experiencing odd crashes and hangs with Claws too. It appears that version 3.8 has some issues in it. Since the Claws team is quite regular with releases, hopefully the next one will fix some of these. –  ShankarG Jun 12 '12 at 8:50

1 Answer 1

up vote 0 down vote accepted

it's not a Claws bug, it's a package dependency bug. I don't know what the package would be called on Pclos, but it's a glib package which is missing.

share|improve this answer
    
thanks much, updating glib packages in Synaptic solved the problem. –  Juhele Jul 5 '12 at 9:43

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.