Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Windows Firewall running. I created a rule called "AllowHTTPAccess" to allow TCP traffic on port 80 for Domain, Private and Public.

She can ping me, but but she can't connect to the web server.

Is there something I can do to get this to work?

share|improve this question
    
Perhaps you're not running a web server? –  Skizz Jun 12 '12 at 12:28
    
Sounds like you've done the 'setting up' part of connecting to your machine covered, do you actually have anything listening on port 80 on your machine? Do you have IIS or equivalent installed to serve the pages? –  user139604 Jun 12 '12 at 12:33
    
I'm running Subversion on port 80 of my machine. I access that locally via HTTP, at http://[my_machine_hame]/svn/etc.. I thought she should be able to also. I suspect it's because the Firewall is blocking HTTP access. –  DaveDev Jun 12 '12 at 12:42

1 Answer 1

up vote 0 down vote accepted

Is she attempting to connect to your web server on an internal network (like, in the same office) or is this from another network (she's across town or in another state)? That's important information. You say "colleague" which implies that she is in the same office... but you aren't very clear on that.

Have you forwarded port 80 traffic in your router to the computer that is running the web server? This is an important step if your colleague is not on the same IP subnet as you are. Your router would need to know what to do with those incoming requests for information. So, if you forgot to do that... meaning you forgot to go into your router and handle the port forwarding, that's something that needs to be done. Also, consider putting the web server computer on a static Internal IP address in the DHCP reservation table. That way, you just forward to one IP address, and you don't ever have to worry about changing that later.

Does your router have a firewall as well? Again, this is something that needs to be expressed in your question, as to whether you have addressed it already, or you didn't even know it was there.

Does your ISP allow you to host a web server on the connection plan you are currently paying for (don't be surprised if they don't, they want to charge money for everything they can)? You might have to change the port you are hosting the web server on, if your ISP blocks traffic on port 80. You might have to use a non-standard port of 81, or 8080 or something else, which would require you to set up some NAT table, or have this different port forwarded through the router and have your colleague always append a :81 or :8080 to the end of the IP address she attempts to connect to. Just as an example, Cox home service in New England blocks port 80 traffic like this, so people can't host their own web servers at home without having to do something like this.

So... is there something you can do to get this to work? Most certainly. Of course, we need to know what you have done so far, and we need to know what you are working with so we can tell you what more you can do.

share|improve this answer
    
Hi Bon, she's in the same office as me on the same domain. I don't think the ISP would have anything to do with this as it's a internal network. Not sure about the router, or even how to check that. I've pretty much outlined everything I've done in the question. –  DaveDev Jun 12 '12 at 12:45
    
@DaveDev What happens when she just connects to http://[your computer]? Not http://[your computer]/svn/blah/etc... –  Bon Gart Jun 12 '12 at 12:46
    
In Chrome she's getting a Sorry.. Could not connect to. I can see in the Chrome network monitor that it sends the request but there's no response at all. –  DaveDev Jun 12 '12 at 12:53
    
@DaveDev If you want to see if it is your firewall that is causing this, turn it off temporarily. –  Bon Gart Jun 12 '12 at 12:55
    
I should have mentioned that I'm unable to turn it off. It appears to be disabled for me. The "System administrator" has turned it off for my safety. It's a 3rd party company and they're a pain to deal with. I guess I'll have to go to them to resolve this if I can't turn that off. –  DaveDev Jun 12 '12 at 13:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.