Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

just swapped out my HP2605DN network printer with a Xerox 8570DN network printer. There were never any issues printing on the HP printer from laptop PCs (wireless) or desktop PCs (wired). I can print to the Xerox across the network fine from any desktop but not from the laptops. The IP address of the printer is and neither laptop (XP and Win7/64) can PING this printer wirelessly but they can if connected via a cat 5 cable. Sometimes, the connection to the XP laptop wakes up but there seems to be no consistency to this. I have a print server at and both laptops and PING and print to this wirelessly so I am fairly sure the network is OK, at least superficially. BTW I am using a NetGear DG834v5 router.

I called Xerox about this yesterday and they told me the problem was with my network. I don't think it is (a) because the set-up worked with the HP and (b) I can print to other networked printers but am a network newbie so any assistance would be really appreciated

Thanks in advance!

share|improve this question
Could you try pinging the printer, then do arp -a and see if you have an entry for – Paul Jun 12 '12 at 14:12
Can you update your post to include the network settings of a laptop, a desktop and the printer? – jmreicha Jun 12 '12 at 14:57
When you installed the drivers for the Xerox printer on each laptop, did the driver installation program connect to the printer, or did it skip that portion of the process? – Bon Gart Jun 12 '12 at 15:42
Did you remove the HP drivers and software? It might be causing some issues with the proper installation of the other. Use their removal tool with caution to ensure you don't remove other working HP printers. – CharlieRB Jun 12 '12 at 19:28

I had this exact problem, and it was strange, some machines connecting and some not.

The cause: A wifi access point on the network had failed in a strange way, causing it to set it's BSID to the mac address of a computer that was on the network, and the Colorqube seems more picky about duplicate mac addresses than other devices. It didn't matter whether laptops were connecting through this access point or another one. The access point was also running rather hot.

Removed the offending access point, and everything works now.

Check your arp tables on the network, and ensure that there are no BSID's conflicting as well.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.