Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to change the terminal size of my Ubuntu in VMWare, and find information hereHow do I change the console resolution of Ubuntu 9.10 Server running on VMWare?. I follow the answer and modify the line GRUB_CMDLINE_LINUX="vga=0x319" in /etc/default/grub, then execute sudo update-grub and restart, finally my Ubuntu is in trouble, the terminal shows nothing at all.

The machine replies very well via ping, but there's no ssh/telnet services available, what should I do to recover my machine? And how to change the terminal size in VMWare?

share|improve this question
    
Do you see the grub menu / prompts before it boots the kernel? –  Darth Android Jun 12 '12 at 14:23
    
No, only text like "error: no such disk" flashes off, then nothing shows. In fact, rlogin may be available, but i cannot login in with putty, it seems putty crashes when i want to type my user name. –  beyonddoor Jun 12 '12 at 14:32
    
If you don't usually see it, it might be set to hide the menu (I can't remember what Ubunutu defaults to on that). Try holding escape about when the system should be getting to the GRUB menu to temporarily disable any attempts to auto-boot the first entry or similar). If you can get to the GRUB menu, you can get to the GRUB commandline and manually boot the kernel without the VGA flag. –  Darth Android Jun 12 '12 at 14:33
add comment

2 Answers

up vote 0 down vote accepted

If you can mount the disk image somewhere that you can point a text editor at /boot/grub/menu.lst, just manually strip the vga= flags out and save. Make sure to fix your /etc/default/grub or update-grub will put them all back when it is next run.

share|improve this answer
    
I have another Ubuntu image, maybe i could boot it and mount the previous one, so i could restore /etc/default/grub. By the way, I press the Esc cannot stop the machine from booting, i don't know why? –  beyonddoor Jun 12 '12 at 14:52
    
@beyonddoor That would work if you mount both images into the same VM and boot from the good one. If <kbd>Esc</kbd> is not interrupting the boot sequence, then perhaps try pressing it sooner, or maybe things have changed since I was last playing with bootloaders. –  Darth Android Jun 12 '12 at 14:59
    
In this link <howtogeek.com/howto/linux/…;, it says the same as you did to show the GRUB menu, in my system, i have never seen the GRUB message. –  beyonddoor Jun 12 '12 at 15:08
add comment

Do you use VMware Player? Can you shut it down? When you can, you will be able to change the resolution of the guest OS in VMware Player. Just go to VMware Player , then choose properties of which guest OS you want to change (right click on it) then choose Virtual Machine Settings and here you go. You can set up how much of HDD space your guest OS is given, how much of RAM... as well as what the display resolution of your guest OS is...

share|improve this answer
    
My Ubuntu works only in terminal mode, so changing the display resolution may take no effect, but i will have a try. –  beyonddoor Jun 12 '12 at 14:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.