Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Trying to install XPmode on Win7 Professional 64-bit SP1, but getting an error.

I downloaded XPMode, Virtual PC and the update as specified here: http://www.microsoft.com/windows/virtual-pc/download.aspx.

When I open XP mode for the first time it goes into the setup ("Setting up Windows XP Mode for first use..."; pick your VM password, etc.), then it runs through the progress bar until almost the end (99%?). At that point I get the error:

Could not complete Setup. Please try again.

Whats going on here? I've uninstalled Virtual PC and xpmode, and reinstalled in several different orders, no luck. Is there some log file that will tell me whats happening? Theres nothing showing up in the Event log that I can find. How can I fix this?

share|improve this question
1  
Take a look on this MS Supoort may be it helps you. Also have you tried the hotfix which is provided in answer. –  avirk Jun 18 '12 at 15:21
    
What is your computer model and motherboard ? –  harrymc Jun 18 '12 at 15:52
    
@harrmc -Computer is a custom build, motherboard is Gigabyte 990FXA-UD3. –  MAW74656 Jun 18 '12 at 16:09
    
@avirk -Yes, tried hotfix as mentioned in comments to the answer below. –  MAW74656 Jun 18 '12 at 16:16
    
So now take a look on that article and ask freely if any error occurred. –  avirk Jun 18 '12 at 16:22

3 Answers 3

up vote 2 down vote accepted
+50

Try installing XPMode after performing a clean boot:

  1. Press Win + R and execute msconfig.

  2. In the General tab, choose Selective startup and uncheck Load startup items.

    screenshot

  3. In the Services tab, check Hide all Microsoft services and click Disable all.

    screenshot

  4. Click OK, then Restart.

(images from Microsoft Support: How to troubleshoot a problem by performing a clean boot...)

share|improve this answer
    
a normal restart is all that I needed –  Tim Partridge Oct 24 '12 at 3:48

If you happen to have an AMD bulldozer CPU/APU there's a Hotfix for that:

Microsoft KB2519949: You cannot install Windows XP Mode on a Windows 7-based computer that has an AMD Bulldozer-based multicore processor installed

When you have an AMD Bulldozer-based multicore processor installed on a computer that is running Windows 7, you cannot install Windows XP Mode. Additionally, you receive an error message that resembles the following:

"Could not complete Setup. Please try again."

share|improve this answer
    
I didn't even think of that. Listed as Zambezi, but since "...Zambezi is based on Bulldozer microarchitecture..." cpu-world.com/Cores/Zambezi.html, it might work! How the hell did you find this? Trying it now. –  MAW74656 Jun 12 '12 at 18:45
    
-No dice. Same error. –  MAW74656 Jun 12 '12 at 19:01
    
-Any other ideas along these lines? –  MAW74656 Jun 15 '12 at 17:34

Remove all bootable CDs or DVDs from your DVD drive (virtual or real). The XP Mode VM might accidently try booting off of that instead of the virtual harddisk image. Found here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.