Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Have Mac desktop with USB printer. Attempting to share with PC over the network. However I get the message: You do not have sufficient access to your computer to connect to the selected printer.

On Mac side, turned on printer sharing for the printer.

On PC side, installed Bonjour. I can see the printer, but when try to connect I get the above message.

How can I get around this error message, and print?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

It appears that the iMac is denying access (to its printer) to the PC based on incorrect login credentials. One could try creating an account on the Mac and using that account to connect from the PC to the printer.

Also, Bonjour is an Apple product. Older versions of Bonjour are very incompatible with Windows 7 and there are numerous web posts dedicated to fixing/removing Bonjour from Windows PCs, especially in relation to Bonjour's mDNSResponder.exe interfering with network access.

There is another way to configure the printer sharing, through SMB and CIFS, which is the Windows-compatible method used by all *nix systems, including Apple (which is FreeBSD under the hood).

On Mac:

  1. In Print & Fax preferences, click Sharing.
  2. Select the "Share these printers with other computers" checkbox, and then select the printers you wish to share.
  3. Click Show All, click Sharing, and then click Services.
  4. Select the Windows Sharing checkbox.

On PC:

  1. To print to your printer using SMB/CIFS, use the Add Printer Wizard to configure a network network printer and use the Postscript printer driver (even though the printer isn't a Postscript printer). The iMac will translate the Postscript code into code the printer can understand.

Above info on CIFS/SMB from: http://docs.info.apple.com/article.html?path=Mac/10.4/en/mh1770.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.