Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

As an Embedded Software Engineer serial port access is very critical requirement for me irrespective off which OS I am using and how I am using it (I mean with or without virtualization).

I have Windows XP as primary Operating System, however, I need to work on Linux for lot of hobby projects. I hate to manage two computers for two reasons first is it makes workplace really messy with extra wires and Second is I always need some space to keep items like Power Supplies, Oscilloscopes, Programmers, Debuggers etc. which are unavoidable.

So I installed Kubuntu as Guest OS on my Windows Host and I wanted to access the host serial port for debugging purposes. Virtual Box does provide this feature and its quite easy to configure as well. The problem is, it can be done in more then one way and that’s where user might get confused that’s why I am writing this post.

share|improve this question
    
What is your question exactly? –  Dave M Jun 13 '12 at 1:07
    
I think he's asking "How do i passthough the serial port from my windows host to my linux guest in virtualbox?" –  Journeyman Geek Jun 13 '12 at 2:57
add comment

3 Answers

up vote 1 down vote accepted

Can you just enable the serial port for that particular VM?

In VirtualBox, make sure your VM is not powered up, and

  • Right Click your VM
  • Click settings,
  • Choose the 'Serial Ports' menu
  • Select which Serial port you wich to pass through
  • Click the checkbox to enable it.

you can also change settings for the serial ports from this screen.

share|improve this answer
add comment

I found this question, and found the existing answer less than satisfactory. Here's how I solved a similar problem.

I have OpenSuSE 12.2 running as a guest on VirtualBox 4.2 on a Windows (Vista) host. I want to communicate with an X10 "Firecracker" serial device. What worked for me was

  Port 1
  [X] Enable Serial Port
     Port Number: COM1  IRQ: 4  I/O Port: 0x3f8 
       Port Mode: Host Device
                  [ ] Create Pipe
  Port/File Path: COM1

The key here, which was not obvious to me, was to select "Host Device" and enter, seemingly redundantly, "COM1" as the host path. I did NOT select "Create Pipe".

share|improve this answer
add comment

Virtualbox allows each VM to have two serial ports. I tried everything under the sun to get this to work on the first of these ports (Settings | Serial Ports | Port 1 tabbed page).

Eventually I removed the check mark from "Enable Serial Port" on port 1 and then tried Port 2 instead. It worked instantly, the Guest could use the host's physical serial port.

Host = Win 7 64 bit Guest = Win XP Pro SP3

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.