Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm configuring an IEEE 802.3ad (LACP) dynamic trunk from a HP Procurve 2412zl (firmware version K.15.07) switch to a HP Proliant DL380 G7 server. The DL380 has 4 NICs and is running Win2008 R2, so I'm teaming the NICs together and leaving everything on the recommended "automatic" setting in the HP NIC configuration tool. The server is one of two, they'll be connected on interfaces F17-F20 and F21-F24 respectively on the switch.

I need the servers in a separate VLAN, here is the configuration for the VLAN:

vlan 10 
name "Lab_Mgmt"
untagged B2,F17-F24
ip address 172.22.71.3 255.255.255.0
tagged B21
exit

There is a DHCP-relay into the VLAN 10 from another device beyond interface B21. The Advanced Traffic Management Guide says that in order to run a dynamic LACP trunk on another VLAN besides the DEFAULT_VLAN, you need to first enable GVRP and then use "forbid" to stop the interfaces from automatically joining DEFAULT_VLAN when the dynamic trunk is created. GVRP brings some other stuff with it that I don't want or need, so I disable it with "unknown-vlans disable" on all other interfaces.

Here is how I do it:

procurve-5412zl-1(config)# gvrp
procurve-5412zl-1(config)# interface A1-A24,B1-B24,C1-C24,D1-D10,D13-D24,E1-E24,
F1-F16,K1,K2 unknown-vlans disable
procurve-5412zl-1(config)# vlan 1 forbid F17-F24
procurve-5412zl-1(config)# interface F17-F20 lacp active

The result afterwards looks all successful:

procurve-5412zl-1(config)# show trunks 

 Load Balancing Method: L3-based (Default), L2-based if non-IP traffic

  Port | Name                             Type      | Group  Type    
  ---- + -------------------------------- --------- + ------ --------
  F17  | XYZTEAM3_NIC1                    100/1000T | Dyn2   LACP    
  F18  | XYZTEAM3_NIC2                    100/1000T | Dyn2   LACP    
  F19  | XYZTEAM3_NIC3                    100/1000T | Dyn2   LACP    
  F20  | XYZTEAM3_NIC4                    100/1000T | Dyn2   LACP    

procurve-5412zl-1(config)# vlan 10
procurve-5412zl-1(vlan-10)# show lacp

                                   LACP

          LACP      Trunk     Port                LACP      Admin   Oper
   Port   Enabled   Group     Status    Partner   Status    Key     Key
   ----   -------   -------   -------   -------   -------   ------  ------
   F17    Active    Dyn2      Up        Yes       Success   0        0     
   F18    Active    Dyn2      Up        Yes       Success   0        0     
   F19    Active    Dyn2      Up        Yes       Success   0        0     
   F20    Active    Dyn2      Up        Yes       Success   0        0     

On the Proliant server, the NIC configuration Tool is also indicating that a 802.3ad dynamic trunk has been established.

Everything should be good, but it isn't. The server is not getting an IP-address from the DHCP, which it does if I'm not enabling LACP. If I configure the server to a static IP-address on the VLAN 10 subnet, it can't even ping the switch IP-address, much less anything outside of the VLAN. The switch can't ping the server either.

I did another attempt with F17-F20 tagged, and checking the box "Default Native Tag (VLAN 10)" in the NIC configuration tool on the server, but there was no difference. Does anyone have any idea what I might have missed?

share|improve this question
add comment

3 Answers

The DHCP server, is it on the same network 172.22.71.3 /24 as the other elements in the VLAN? If not, I think you should specify the DHCP-relay IP address on that VLAN with:

ip helper-address @DHCP-IP-Address
share|improve this answer
add comment

I dont see here where the Dynamic trunk is put into vlan10. you would need a vlan 10 untag trunk Dyn2 or something to that effect. If that doesn't work try creating a static trunk.

share|improve this answer
add comment

On ProCurve switches, dynamic LACP really won't work with VLANs other than VLAN 1.

Something you seem to have overlooked: in your switch console log, the "show lacp" command is acually NOT restricted to VLAN 10, even though you're in the VLAN 10 config context. It simply outputs all dynamic trunks, irrespective of the VLAN configuration.

The GVRP statement from the ProCurve documentation looks like some kind of practical joke... I doubt the person who wrote this actually ever got it working.

Since you're dedicating specific ports to your servers, why not just use static (active) LACP anyway? Then you can assign your Trk trunks to whatever VLAN you like.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.