Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I try to connect from work to my laptop in home via Remote Desktop Connection, but I can't. On work I use PC with Windows 7, at home laptop is with Windows 7 + router.

In "System Properties" I checked "Allow Remote Assistance...", on Remote Desktop is second option "Allow Connections from computers running any version of RD".

Remote laptop has username+password.

Also I switch off Firewall on laptop and firewall on router just to try and nothing happen. Got message "Remote Desktop can`t connect to the remote computer..."

I'm really stuck on this and any help will be appreciated.

share|improve this question
    
"at home laptop is with Windows 7"... Windows 7 what... Professional? Ultimate? Because you won't be able to RDP into Windows 7 Home Premium. Just like XP Home and Vista Home Premium, Windows 7 Home Premium doesn't include all the necessary files to accept RDP connections. Doesn't matter what the checkbox says. You'd have to hack your version of Win 7 home to think it was Pro, and even then, some report that SP1 breaks the hack. andrewblock.net/2010/02/23/… –  Bon Gart Jun 13 '12 at 9:46
    
Home laptop is - Windows 7 Ultimate. Work PC is Windows 7 Proffesional. I`m sorry forgot to mention. –  Jason Paddle Jun 13 '12 at 9:49
    
no problem. Just making sure. –  Bon Gart Jun 13 '12 at 10:14
add comment

2 Answers

up vote 2 down vote accepted

If you have a NAT router, disabling the router firewall may not be enough. Did you set up a port forwarding rule?

To be able to connect to your laptop at home, you have to set up a port forwarding rule which forwards an external port of your choice to the internal port 3389 (remote desktop) of your laptop.

Let's say your external ip is 1.2.3.4 and the internal ip of your laptop is 192.168.0.20. You could then create the following forwarding rule:

1.2.3.4:55555 -> 192.168.0.20:3389

This would forward external port 55555 to the remote desktop port of your laptop.

If you correctly disabled the firewalls on your router and laptop, you should be able to get a remote desktop connection from work using 1.2.3.4:55555.

share|improve this answer
    
OK i will try this. What port i need to put on external- 55555 ? or other ? –  Jason Paddle Jun 13 '12 at 9:19
    
I can't see where in router i can set this rules. Router is MSI RG54SE II. In menu 'Forwarding' i have 'Virtual Servers', 'Port Triggering', 'DMZ' and 'UPnP' –  Jason Paddle Jun 13 '12 at 9:31
    
@JasonPaddle Go to Virtual Servers, add a new one. Then choose Service Port 3389 and insert the internal ip of your laptop as IP Address. Choose TCP as Protocol and Status enabled. This way you will forward external port 3389 to internal port 3389 of your laptop. –  speakr Jun 13 '12 at 10:30
    
done, but still no connection Image –  Jason Paddle Jun 13 '12 at 10:52
    
@JasonPaddle You can try a port scan e.g. with nmap to see if port 3389 is really open: If you get a port filtered result, some firewall is still blocking. If you get a port closed result, your port forwarding works and your firewalls are disabled, but your remote desktop service is not enabled. –  speakr Jun 13 '12 at 10:58
show 1 more comment

Do you have another machine you can connect to the network local to your home laptop and test the RDP connection from that machine to your laptop. That would test whether RDP is working at all on this pc and possibly point a finger at the router / firewall settings.

share|improve this answer
    
No, i have only one external and one remote –  Jason Paddle Jun 13 '12 at 9:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.