Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a laptop with 1 LAN card port, that i plug to a switch. That switch is connected also to a server.

If i ping the server from my laptop, i get reply when i opened the VMs, i get weird ip dynamically. instead of the normal 192.168.1.XXX (DHCP) i got 192.168.192.128 and the other VM got 192.168.192.129.

If i ping my laptop which is at 192.168.1.7 or the server 192.168.1.100 from one of the VMS then it get reply, but if i try to ping 192.168.192.128 from the 192.168.192.129 VM.. i dont get replay.

So.. i have connection between the VMS and my laptop/server, but i dont have connection between my VMs.. how can i fix it ? i choose NAT on the VM setting.

Thanks

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

If you create a virtual machine in VMware you can selected if they use bridge network or if you want to use a local network.

If you select bridged than the appear as normal hosts on your network and get their IP from your normal DHCP server. There should not be any conflicts.

The other setting uses a local network and its own network range.

Check these settings.

share|improve this answer
    
I checked "Bridged: connected directly to the physical network" on both VMs, but they get dhcp ip that looks good like: 192.168.1.5 (sequential numbering). If i ping my laptop / other VM, i dont get reply, if i ping the gateway / server that attached to same switch - i get reply –  ilansch Jun 13 '12 at 14:16
    
OK, i used bridged connection, and then it worked ok. the problem i guess was to shutdown the windows firewall. now i can ping each VM from the other VM. –  ilansch Jun 13 '12 at 14:25
add comment

You can simply manually assign an unused IP from the 192.168.1.X subnet to each VM That would be a quick and easy fix.

share|improve this answer
    
I tried, i do not know the DNS Server to enter in the IPV4 setting.. so if i just enter the IP address, mask and gateway - then the VMs dont communicate with each other and dont communicate with the laptop/server also.. –  ilansch Jun 13 '12 at 14:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.