Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have some files on my SSD and I want to put them on my Ubuntu 12.04(64bit) desktop , but Ubuntu cannot open the exFAT SSD when I connect it via USB. How can I make it work?

share|improve this question
3  
askubuntu.com/questions/14838/… –  vcsjones Jun 13 '12 at 16:16
add comment

3 Answers

up vote 31 down vote accepted

exFAT is a proprietary file system developed by Microsoft, and implementing it requires accepting a very restrictive license from Microsoft. However, there is a FUSE implementation of exFAT for linux.

Since you are on a Ubuntu system, you can install the above-mentioned exFAT implementation from their PPA.

  1. Add the PPA to your sources list by running

    sudo add-apt-repository ppa:relan/exfat
    

    in your favourite terminal emulator

  2. Install the fuse-exfat and the exfat-utils packages:

    sudo apt-get update && sudo apt-get install fuse-exfat exfat-utils
    

Now you should be able to use the SSD

share|improve this answer
    
This worked quite well for me. Didn't even have to reboot. Though for some reason it wouldn't install directly, so I just did a sudo apt-get -d download fuse-exfat followed by sudo dpkg -i path/to/file.deb ftw. –  MarkHu Jan 10 '13 at 21:02
    
Worked like a charm with my 12.04 using these commands but within a sudo shell (sudo -s) instead of "sudo .." for each commands. –  Jay Jan 20 '13 at 20:58
1  
Worked for me in 12.04 as described. No need to "sudo -s". –  mivk Jun 28 '13 at 10:35
1  
Same for me, no need for sudo -s –  loostro Feb 3 at 9:08
add comment

If this is a one time copy of those "some files" then either:

  • partition that SSD into two, the second one to FAT, meet any of your friend who have Windows and you are done (or have your FAT formatted pendrive along with you, and skip the partitioning advice), you can even drink a coffee or chat during the process, or:
  • install VMWare, then download a Virtual PC image, convert it to VMDK, and pass through your USB port to the Windows Guest machine (and set up a shared folder between Guest and Host beforehand).

The second is for introverted geeks, or people with a 1 hour deadline in the middle of the night.

share|improve this answer
    
Insanely complicated answer. Install Windows in a virtual machine instead of just installing the exfat driver?? –  mivk Jun 28 '13 at 10:38
    
Then you don't understand the second bulletpoint, which instructs the OP to install a virtual machine (a Windows) by downloading a virtual OS image. –  karatedog Jun 28 '13 at 14:36
1  
I do understand. you suggest to do a 700MB download from MS, find the right tool to convert the image to vmdk, install vmware and configure it for USB pass-through. Sorry, but that is crazy when a simple driver exists and can be installed in under 30 seconds. –  mivk Jun 29 '13 at 11:20
add comment

To install exfat on Ubuntu 13.10 Saucy Salamander, you don’t need to add any extra PPA to your sources list. You only need exfat-utils package

$ sudo apt-get update && sudo apt-get install exfat-utils

Ubuntu and Linux Mint will not automatic mount exfat devince. To mount exfat device, plug in your device and run:

$ su -
# cat /proc/partitions
# cd /media
# mkdir usbdrive
# mount -t exfat /dev/sdd1 usbexfat

From http://namhuy.net/872/how-to-enable-exfat-on-ubuntu.html

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.