Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a freshly installed Debian squeeze amd64,

$ ls /media -l
drwxr-xr-x 2 root root 4096 Jun 13 12:13 usb0

But after mounting,

$ mount /dev/sdb1 
$ ls /media -l
drwx------ 1 root root 4096 Jun 12 18:11 usb0

which makes the mount-point unusable for the user who mounted it.

fstab entry

/dev/sdb1       /media/usb0     auto    defaults,rw,user,noauto  0       0

Is there a fix that enables the user to make the mount-point easily accessible to the user with the mount command itself (instead of a separate sudo chmod command)?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

check the umask mount options:

/dev/sdb1       /media/usb0     auto    defaults,rw,user,noauto,umask=022  0       0
share|improve this answer
    
umask option alone did the trick –  fayaz Jun 16 '12 at 20:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.