Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a machine that I'm trying to troubleshoot -- could be a hardware problem, could potentially be a software problem. It's a Dell PowerEdge 2950 (with a couple of dual-core 3.5GHz Xeons) and I've just installed CentOS 6.2 on it.

If I do 'dd if=/dev/zero of=/dev/null', I get transfer rates of around 30 MB/s. On other similar machines, I'm getting 500 MB/s or even 1.2 GB/s. So something is clearly amiss -- as far as I can tell, something must be sucking up the machine's CPU power (that dd doesn't do any I/O), but neither mpstat nor sar shows me anything obvious. Nor are there any messages in /var/log/messages or /var/log/dmesg that tell me about re-presenting interrupts or the like.

So I'm somewhat out of ideas -- the machine is clearly sick but I can't figure out how. I'd love any bright ideas for things to try!

share|improve this question
    
troubleshooting is troubleshooting, regardless of what has the issue. Remove any preconceived notions you may have, detail every possibility regardless of the probability, loosely organize the possibilities as most probable first, and start going through them. For example, if you suspect the OS is at fault, remove the OS by booting to a LiveCD environment. Then test. –  Bon Gart Jun 13 '12 at 23:46
add comment

1 Answer

Grab a livecd, and start with a few basic tests.

Start with memtest (to make sure your ram is fine), and work your way down. I'd suggest running smartmontools and running an extended test. Look for old age and pre-failure related issues - i find that these are the main reason hard drives slow down.

This question on serverfault suggests some tools to try as well.Here's the search parameters i used should you want to trawl through SF for more ideas.

Finally, have you tried just swapping the drives with known good ones to see if that makes a difference?

share|improve this answer
    
I'll try those when I'm back in the office tomorrow... but I'm pretty sure it's not the hard drives. dd from /dev/zero to /dev/null doesn't touch disk anywhere. –  Alistair Bell Jun 14 '12 at 1:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.