Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

IP 192.168.1.5 has a wireless connection to a Linksys router (192.168.1.1) which then is connected to a switch. The switch is connected to a server (192.168.0.2). My printer has IP address of 192.168.0.8. Internet connection is fine on 192.168.1.5.

  • Problem 1: IP 192.168.1.5 can not print using printer 192.168.0.8.
  • Problem 2: IP 192.168.1.2 can not access a shared folder on the the server.

The reason for connecting this way is that, the server does not release wireless signal. In order to get wireless signal the Router is connected to the switch. The server is a computer server that only has one outgoing LAN port. Plus, due to inconvinience physical locations, I do not have option to change the physical locations and the way it is connected already.

I just want the labtops that only have wireless connection to communicate with the printer and the server.

I have tried to change the router IP address to 192.168.0.x like the server and printer. It caused problem for the laptop. The router no longer release internet signals.

The router does have IP address from the server 192.168.0.5.

share|improve this question
1  
I've converted your posts below in to real comments for you, but the reason you couldn't do this yourself is because you essentially had a different account each time you visited (which I've now merged together). Either you need to register a full account, or you need to make sure you keep cookies from this site and use the same browser each visit, or you need to use the recovery options provided on the login screen (linked in the header) each time you come back. I'd recommend registering a full account as a the most reliable (you can do so on the login link in the header). –  DMA57361 Jun 14 '12 at 9:11
    
To print your documents your printer and Pc should be on the same network i.e either on 192.168.0.x or 192.168.1.x network. either connect the Pc to the switch or the printer to the wireless router. –  tiki Jun 15 '12 at 8:38
    
Robert, please take a moment to register your account. That way you will retain control over your posts even if your browser cookie is lost –  Sathya Jun 15 '12 at 8:50

6 Answers 6

It seems that you connect Linksys router to the switch because you want to have wireless accesspoint. IP 192.168.1.5 would be a laptop that has wireless connected to Linksys router. Is it correct? The printer is directly connected in wire to the Switch.

Your problem is obvious. Your printer is connected to a network of 192.168.0.X and your laptop is on 192.168.1.X network.

Have you try this? Connect the printer to Linksys router instead of the Swtich. This will work.

share|improve this answer
    
@Guru.. thanks for your answer. My problem is that there are a couple of PCs directly connected to the switch in wire connection. And I want them to stay the same condition because when I move printer from the switch and connected it to the router, the two computers can not print any more. I even tried this, I changed the router IP address from 192.168.1.1 to 192.168.0.9, it does not work. Please help me out. –  Robert Memo Jun 14 '12 at 1:30

Disable DHCP on the router. It will work. Your problem (1) and (2) are the same. By the way if you want to access in to the router type 192.168.1.1 on any browsers and then admin is the username and the same is password or password is password, or whatever setup as password is password.

tell me what happen when you disable DHCP

share|improve this answer

It's because you are trying to access devices that are on different subnets, and you have no Network Address Translation (NAT) set up at the router. You can set up a specific route on each machine to the device(s) you want.

There are a couple of options.

  1. Change the IP subnet that the linksys router is on to match what the server is on. You already tried this, but you'd just need to turn off DHCP on the Linksys router, make sure that it was set to Automatic DHCP for the Internet Connection type from the Basic page at the Admin page. This should and can work, since I'm looking at the Admin panel of a Linksys WRT54G2 that is on my network right now. My main router (WRT160N) that handles DHCP has a DHCP reservation table entry for the second router, and the second router is set up with DHCP disabled. Any computer that connects to the WRT54G2 gets an IP from the main router on the same subnet. OR

  2. Setup a static route in the linksys router to the server. The destination would be 192.168.0.0, the subnet mask of 255.255.255.0 and the gateway of 192.168.0.1 (should do the trick) in the advanced routing off the setup page in your router admin panel

  3. Add a specific route on each Windows machine that you need to access the devices. route add 1912.168.0.8 mask 255.255.255.0 192.168.1.1 from the machine that wants to access the printer, and route add 1912.168.2.0 mask 255.255.255.0 192.168.1.2 from the machine that wants to access the server. Similar to the NAT settings. But this is the most restrictive, as it would require custom settings on each computer.

Now, all this depends on how your network is really set up. What device handles DHCP? Where does the internet connection come in, etc.

share|improve this answer
    
@ Bon .. Thanks for this answer. I still have problem. The internet come through the server --> switch > router > laptops (two laptops). The diagram is like this {Internet} -> (Server) --> [16 ports Dlink Switch]-->(printer)(PC1, PC2)|(Router)-->(laptop1, laptop2) I have set the same subnet. 255.255.255.0 the server also has this subnet, so as the printer. - When I disable DHCP, will this effect as internet connection problem to my second labtop? And I want both of laptops, that are connected internet only via the Linksys router, have ability to print in the printer 192.168.0.8. I am still hav –  Robert Memo Jun 14 '12 at 2:09
    
If the Linksys router is given an IP address that would normally be handed out by the server (assuming that it passes out DHCP to whatever is connected to the switch), it should then work as a pass-thru, allowing that server to also give IP addresses to the laptops. This would mean the laptops wouldn't be 192.168.1.5 and whatnot, but rather 192.168.0 x, thus on the same subnet (255.255.255.0 is a subnet mask). This also assumes that the server is handling DHCP for everything connected to it. If it isn't, then you would have to also put in DNS settings into the router. –  Bon Gart Jun 14 '12 at 2:34

The problem you have at the moment is twofold. Firstly, the AP/router doesn't even have a secondary IP for the 192.168.0.x network so it won't even be able to send traffic to the printer or server from the AP itself. Secondly, there is no route that allows devices to talk to each other across both of those subnets.

Normally with home wifi access point/routers you put your LAN address 192.168.0.x and your wifi network address on the same subnet. If you do that, all your problems will be solved.

So your AP address should be 192.168.1.1 therefore your DHCP range I'd make something like 192.168.1.100 - 192.168.1.254 with default router and DNS 192.168.1.1

This DHCP will also serve all the clients off the switch side. If you want those statically set up (which is a good idea) then change them to be 192.168.1.2 (server) and 192.168.1.8 (printer) and set their subnet subnet masks to be 255.255.255.0, default router 192.168.1.1 & DNS 192.168.1.1. Because the last number in the IP address is below 100 you won't have any issues with the DHCP server stealing those addresses.

share|improve this answer

The internet come through the server --> switch > router > laptops (two laptops).

The diagram is like this {Internet} -> (Server) --> [16 ports Dlink Switch]-->(printer)(PC1, PC2)|(Router)-->(laptop1, laptop2)

It looks to me your caught between two different broadcast domains. first one being (Server) --> [16 ports Dlink Switch]-->(printer)(PC1, PC2) and the 2nd (Router)-->(laptop1, laptop2)

Not knowing your Physical restraints with equipment i think it would be Ideal to have

{Internet} -> (Server) -->|(Router)--> (printer)|[16 ports Dlink Switch] --> (printer)(PC1, PC2)(laptop1, laptop2)

you could either connect the printer direct in to the router or in to the switch with this.

This should keep everything. using DHCP under the same IP network / broadcast domain. You server getting the Wan IP address from you ISP and the rest of your devices IP's from your Router.

share|improve this answer

Disabling DHCP server on the router will cause problem for internet connection to other laptops unless you manually enter the IP address, subnet, gateway and dns accurately. I do not recommend 'to disable DHCP server' in this situation. It would not help at all.

You will have to configure your printer in such a way that it can communicate with you laptop. It is possible. the problem lies at the printer not at the router or the server at all.

The same thing apply to your problem 2. Configure your server so that it would be able to communicate with your laptop.

The problem is not in the router or IP setting, DHCP setting of the router... router is just fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.