Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to trick the results in this page to have more privacy/anonymity:

So far the best I could do is change the user agent, with the "User Agent Switcher" plugin.

Any ideas on how to change the other values? Like the plugin details and the system fonts.

share|improve this question
What are you trying to accomplished by doing this? – superuser Jun 14 '12 at 1:14
@David More privacy. Not letting random websites gather every bit of information about you is generally a good idea. – HappyDeveloper Jun 14 '12 at 1:20

4 Answers 4

up vote 2 down vote accepted

There isn't a way to do this yet in Firefox. This is necessary so that the server you are connecting to can know what form to send the content back to you in. The closest analogy I can draw is how SSL sends all of the acceptable connection types (SSL1, TSL, etc.) and the server can pick what it wants to use to communicate. When we are sending all this information to the server we are letting it know that we have these plugins and it can send us content we will be able to use.

If you're concerned about security on your browser, you could use NoScript to block unnecessary scripts from running on your browser. That's means it'll more likely make your browser less "unique".

share|improve this answer

For user-agent, you can use "about:config" to create a value called "general.useragent.override" and setting the value to blank (or your favourite user agent).

Setting "plugins.click_to_play" to "true" stops the font enumeration.

"" to "false" might also be useful.

share|improve this answer
This is actually a better answer! The system fonts are read through flash, so "plugins.click_to_play" effectively solves the problem. – Memming Aug 10 '13 at 3:45
shure about that? i have that value set to true and my fonts stil gt enumerated – rhavin Nov 18 '14 at 6:35

I know this question is quite old, but when searching for this problem, this is one of the first results.

Short Answer: Set "plugins.enumerable_names" to "" (empty string) on Firefox 29+.

Apparently, from version 29 onwards, Firefox has a setting on about:config that controls the enumerable plugins. It does not solve the problem completely, because it is possible to query individual plugins, but it helps.

This property is "plugins.enumerable_names", and it has a list of allowed prefixes that can be enumerated. So, for the default setting, "Java,Nexus Personal,QuickTime,Shockwave", all plugin names starting with "Java", "Nexus Personal", ... will be enumerated, and all others will be hidden. To hide everything, just clear that string (set it to "").

More info:

UPDATE: As Pointy has mentioned in the comments, this feature has been removed, since it didn't really prevent plugin enumeration (but made it slightly harder).

Here is the bugzilla page for the patch:

UPDATE2: After a quick search, it seems like the only thing that prevents plugins from being enumerated is setting them to "Never activate". In the meantime, removing extra plugins and randomizing the user agent might help.

share|improve this answer
There's no plugins.enumerable_names config property in Firefox 42. – Pointy Nov 16 at 20:40
Thanks for the warning. It appears they removed because it was pretty much useless (you could still have a list of plugins and test one by one). I'll update the post with what I find in the meantime – Daniel Vaz Nov 17 at 22:26

fyi, check out this Firefox Addon: Random Agent Spoofer

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.