Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed Virtualbox on my workplace laptop to run Lubuntu in Windows-7 64-bit. I have some issues to make the hostonly network work with wireless adapter.

The wireless adapter will turn off once wired adapter is connected.

When I disconnect the wired adapter, wireless network doesn't turn on. Current active network points to Virtualbox Hostonly adapter. Only after I disable the hostonly adapter, I can turn on wireless adapter.

How can I make the wireless adapter turn on without disable virtualbox hostonly adapter?

share|improve this question

migrated from stackoverflow.com Jun 14 '12 at 2:21

This question came from our site for professional and enthusiast programmers.

2  
Not really programming related. –  Filburt Jun 12 '12 at 8:40

1 Answer 1

VirtualBox doesn't correctly notify Windows 7 that the Host-Only Adapter is virtual. As a result, it shows up as an unidentified public network. It sounds like that may be the source of your problem.

To correct the issue, you must make a minor addition to the registry. First you need to locate the key associated with the VirtualBox host adaptor:

  1. Under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E972-E325-11CE-BFC1-08002BE10318}, locate the key containing the string DriverDesc with a value of "VirtualBox Host-Only Ethernet Adapter"
  2. Within the key you located (something like '00XX'), add a DWORD value with the name "*NdisDeviceType" and a value of "1".
  3. Reboot.

Additional rationale for making this change and examples of PowerShell scripts that can automatically make it for you can be found here or here. I have not tested either PowerShell script, so your mileage may vary.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.