Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using CentOS 6.2, and I tried to install VLC Player using yum, but it shows "No package vlc available". I tried below command:

[root@localhost ~]# yum install vlc
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * base:
 * extras:
 * updates:
base                                                     | 3.7 kB     00:00     
extras                                                   | 3.5 kB     00:00     
updates                                                  | 3.5 kB     00:00     
updates/primary_db                                       | 3.4 MB     01:17     
virtualbox                                               |  951 B     00:00     
Setting up Install Process
No package vlc available.
Error: Nothing to do

Is there any rpm package available?

share|improve this question
up vote 1 down vote accepted


Perform Following Steps to Install VLC Player on RHEL 6.x / Cent OS 6.x on 32 or 64Bit :-

1) You have to be root to execute this script.

2) Download RPM ( Auto VLC Redhat Centos6) which I have specially created for VLC Installation Script , You can use RPMs for CentOS 6 too.Click on Following link to Download RPM for Your Architecture :-

32 bit Users click on this link :-

64 bit Users click on this link :-

3) Execute Following Commands as per your Respective architecture :-

For 32 Bit Architecture :-

rpm -ivh avrc6-tejas-barot-linux-0.1.0-1.el6.i386.rpm

For 64(X86_64) bit Architecture :-

rpm -ivh avrc6-tejas-barot-linux-0.1.0-1.el6.x86_64.rpm

4) Download VLC Installation Script for RHEL6 and CentOS 6 , Click this link :-

5) Execute following Command where you have downloaded the script. [root@ask4itsolutions ~]# chmod +x

6). Now Execute your script by two ways mentioned below

[root@ask4itsolutions ~]# sh


[root@ask4itsolutions ~]# ./

7) Once you Execute it will ask you 4 Options to Install as per your OS and Architecture and 5th Option for Exit Select Option as per your OS and Architecture

Press (R32) to Install VLC on RHEL 6.x on 32bit Press (R64) to Install VLC on RHEL 6.x on 64bit

Press (C32) to Install VLC on CentOS 6.x on 32bit Press (C64) to Install VLC on CentOS 6.x on 64bit Press (E) to Exit anytime

Please Enter your Selection:

8) Remember you have to be normal user to run VLC Player, You cannot Run VLC Player as root.

share|improve this answer
-1, you copied this from somewhere and didn't even attribute it properly. Please, link to the original source, and copy as little as possible. If you copy something, at least wrap it in blockquotes. Otherwise this is plagiarism. Try to describe the steps in your own words. Ping me when you fixed your post. – slhck Jun 14 '12 at 8:51
I tried your method and its working fine... thanks a lot – max Jun 14 '12 at 11:15
@suraj You can accept the answer if it helped you. superuser, please at least include the link where you got that from. – slhck Jun 14 '12 at 18:24
Inside that script the original source detail is available. – max Jun 15 '12 at 6:04

VLC must not be in your repository. I think you should add rpmfusion to your repositories. Rpmfusion includes some media software, and plugins for mp3 and mp4, etc....

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.