Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My Windows Vista installation is using a USB key to connect to my wireless router.

Before, I had the computer connected with a LAN cable, at which point my VM (Virtual PC) "saw" the Internet just fine.

I now installed a Plantex USB key (WPA2) and my Windows Vista works just fine (installed their driver).

The VM doesn't see anything though. I installed the driver and still nothing. I don't even have the Windows wireless thingy on the VM that you can click to see networks.

What to do?

share|improve this question
up vote 0 down vote accepted

From Virtual PC Guy's WebLog, his solution:

  1. Created a new internal virtual network, and called it “Bridged virtual network”.
  2. Configured my virtual machine to use this virtual network.
  3. In the parent partition I then opened the Network from the Start menu and selected Network and Sharing Center followed by Change adapter settings.
  4. Next I selected both my wireless network adapter and the virtual network adapter for my “Bridged virtual network”.
share|improve this answer

The virtual machine will not see it as a wireless card, but just as another regular LAN connection. It should therefore connect the same as the old one did, whether that's by NAT, Shared, Bridge or Host Adapter.

share|improve this answer

The virtual machine generally uses its own virtual network cards to access the network. It might be worth looking at the network settings on the VM from the VM software rather than the OS inside. For instance, in VirtualBox you look at the device options from the VirtualBox software. Usually you have the choice of which of the host computers network cards you want to use for the virtual machine's virtual network cards. It's probably still set to the LAN card.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.