Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Similar to sudo chmod -R 777 /, but for Windows 7. A customer decided he hated the prompts for administrators to continue, so he gave himself Full Control for the Everyone group on Windows 7. Now, some fun issues ensued:

  1. Programs do not install
  2. Items normally requiring an Administrator do not run or show the CONSENT.EXE program asking permission
  3. UAC is still on, but not activating (Yes, I checked)
  4. System Restore does not fix this.

What I would love in an ideal world (which I know is not always the case) is a script that would set the permissions of all the default Windows items in the NTFS ACL list. Barring that, I do understand that a re-install would be necessary... However, since a "repair" install requires Administrative rights, I have a weird feeling it would be a clean install. I don't mind, but it may show the customer that he should ask next time :-P

EDIT Update...

I tried avirk's solution, but that did not work. I also tried soandos's answer of running icacls * /T /Q /C /RESET, but to no avail. I have done a repair install, and am evaluating how it acts (installing updates, installing software, etc).

share|improve this question
1  
You can also try SubInAcl to fix installation error. –  avirk Jun 14 '12 at 17:36
    
@avirk Why not post that as an answer? I'll try both yours and soandos' answer tomorrow when I get onto his computer –  Canadian Luke Jun 14 '12 at 19:36
    
@avirk Just read everything on the site, made a batch file for it, and will try tomorrow morning –  Canadian Luke Jun 14 '12 at 23:58
    
@avirk Nope, that technique did not work –  Canadian Luke Jun 19 '12 at 17:04
add comment

2 Answers

Use:
icacls * /T /Q /C /RESET

If that does not work you can reset the permissions manually.

If the only thing that that was changed is that Everyone was granted full control to everything, then the solution would be to take away all permissions for everything, then give it read permissions to the necessary system files (Program files, etc).

You can do this though the GUI option in windows explorer (make sure to apply this change to all subfolders as well), or using the icacls command, with the /T flag.

share|improve this answer
    
Tried, but installs still fail. I do, however, have the CONSENT.EXE UAC prompt appearing now :) I ran the command as admin in the recovery console, since CMD wouldn't open for me as an elevated user –  Canadian Luke Jun 14 '12 at 23:50
    
The manual way failed as well? –  soandos Jun 15 '12 at 11:16
    
I don't know the extent of the permissions and what all should be applied where. I'm going to try the SubInACL tip above today –  Canadian Luke Jun 15 '12 at 14:35
add comment
up vote 0 down vote accepted

Unfortunately, it turns out that it affects Windows enough that a FULL re-install is all that would fix this. I backed up the user data I could find, wiped the C:\, and reloaded Windows from scratch

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.