Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The Snow Leopard Services menu tells me it's "Building..." but it's been over an hour and the status is still the same. How long is this process supposed to be?

share|improve this question
    
The Services menu went back after a few minutes of posting this message. How long does it normally take for the Services menu to rebuild itself when a new service is added? –  Francis Sep 19 '09 at 7:35
    
Have you tried rebooting..? –  dbr Oct 28 '09 at 20:50

2 Answers 2

up vote 1 down vote accepted

You can manually rebuild the LaunchServices database by entering the following in the Terminal:

In Snow Leopard (thanks to Lawrence Velázquez for pointing this out):

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

In older versions of the Mac OS X:

/System/Library/Frameworks/ApplicationServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

Or read more online where I found the tip: http://www.macosxhints.com/article.php?story=20031215144430486

I went to the trouble of adding this as an alias in my .bashrc file so I could rebuild at whim.

share|improve this answer
    
This command is no longer the correct command in Snow Leopard. The executable is located at /System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.fram‌​ework/Support/lsregister. –  Lawrence Velázquez Dec 29 '09 at 22:30
    
Updated. What's strange I find is that when I run my alias, the command I originally supplied still worked. When I copy-pasted it out of my .bashrc, it failed with a File Not Found. Very strange, I have no idea why it continued to work for me, but thanks for noticing the error. –  Kio Dane Jan 5 '10 at 13:36

Try logging in to your Administrator account. After this, let it build. For my Finder it did not take more than 2 seconds. When you get a list, it will also be available to all your 'Standard' user accounts.

Cheers :) BBX

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.