Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I accept a Remote Assistance request in Windows Live Messenger, I immediately get the following message:

Reconnect to Messenger

Your connection with Messenger has been lost.

Reconnecting in 0:59 seconds.

The person requesting the assistance sees that I've accepted the request but they don't see any problem on their side.

However, if the other person emails me a Remote Assistance request file (Invitation.msrcIncident), I can connect to them with no problem. Because of this, it doesn't seem to me like it's a networking issue. It works with my Win7 firewall off or on, and I have TCP port 3389 forwarded from the router to my machine. But I get the same results whether the requesting side is inside my router or outside of it.

I'm on Windows 7 Ultimate with the latest version of Windows Live Messenger (Version 2011 - Build 15.4.3555.308). The requesting side doesn't seem to matter, but I've tried it with XP and Windows 7.

share|improve this question
    
just out of curiosity, what happens when you put your computer in the DMZ in your router... just as a test? Also, support.microsoft.com/kb/306298 That is an important read. Windows Messenger RDP requests don't use 3389. They use a dynamically assigned port greater than 1024. Step 3 in that article. I know... doesn't cover why Windows Live Messenger gets killed. –  Bon Gart Jun 15 '12 at 1:02
    
check your logs? Users\<user_name>\Documents\Remote Assistance Logs –  Jeremy W Jun 15 '12 at 5:14
    
@Bon: I tried making my PC be the DMZ server, but no change. Thanks for the link, but since both PCs are inside my router, I think all the ports should be wide open, shouldn't they? –  Russell G Jun 15 '12 at 15:27
    
Ports @ the router, yes. But turning off the firewall on the machine that has the WLM disconnection issue should have opened up the ports on that machine. It's almost like one or more ports that WLM are using are getting closed at the request. Check this support.microsoft.com/kb/2027572 for all the ports that WLM 2010 uses. And what about straight RDP? And you shouldn't have to forward ports through the router, for machines on the local network. –  Bon Gart Jun 15 '12 at 15:36
    
@Jeremy: Thanks, yes I did actually. I saved a log from just before I clicked Accept to just after. I didn't get much from looking at it, but you're welcome to take a look: chocolatesoftware.com/misc/MsnMsgr.txt –  Russell G Jun 15 '12 at 15:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.