Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using the latest version of Thunderbird with 3 Gmail accounts.

Every time I launch it it seems it's downloading all my messages again.

I've compacted folders (is the action working for the 3 accounts or do I need to do it for each of them?) and deleted the .msc files but nothing change.

It leads to a software using a lot of bandwidth and being very slow when using it. It's a pain to write a message or even to view one. All the software is so slow I've never seen that it's almost unusable.

I'm using thses addons :

  • Dictionary
  • Google Calendar
  • Lightning

My Gmail accounts are configured to imap.

share|improve this question
    
same setup here. and cpu is going 100% these days. doing nothing. –  boomhauer Jan 26 '13 at 21:42

5 Answers 5

  1. unsubscribe the "All Mail" folder for each gmail account. if subscribed you are doubling the download size
  2. try startup in safe mode - http://support.mozillamessaging.com/en-US/kb/safe-mode - is startup speed more "normal"?
  3. you say it "seems" like it's downloading everything again. does tools | activity manager indicate that? Or are you assuming that because it takes so long?
share|improve this answer
    
When you say "unsubscribe the All Mail folder", you mean uncheck "Keep message archives in" right? It doesn't seems to download everything again, it happens sometimes, and it's not everytime. Most of the time Thunderbird just freeze few seconds when I try to do an action, like opening an email, deleting a batch, even typing sometimes! For example I deleted 19 emails in a row, selecting them made the software freeze for 2-3s and deleting for 5-6s. –  DevAntoine Jul 10 '12 at 6:12

In Account Settings, go to "Synchronization and Storage", select "Advanced", and uncheck the "Download" column for the "[Gmail]/All Mail" folder.

share|improve this answer

It is a pain to write a message

This answer might help performance while writing email. A problem with the default setup (Thunderbird 17.0.3) is the settings for draft storage and auto-saving. By default, Thunderbird will auto-save your email every 5 minutes. If you have the "save drafts to [GMAIL] Drafts" option like suggested the following will happen:

  1. Every five minutes Thunderbird will save the email as a draft in gmail servers.
  2. If there was already a draft saved, it will delete it prior to creating the new one.
  3. The effect of deleting it will be to place it in gmail's trash folder.

All this communication with gmail servers results in severe slow-down while writing emails. A few work arounds include:

  • Disable auto-saving
  • Use this extension to redirect the auto-saved drafts to a local folder

This should partially solve your performance issues.

UPDATE: A second thing you should do for the version of Thunderbird I am using is either to disable Thunderbird's indexing, skip "all mail" from being indexed, and/or allow the indexing to finish before continuing to use Thunderbird. The first time Thunderbird indexes all your gmail email it will behave very strangely. If you look at the process footprint it will almost look like Thunderbird is leaking memory for no reason. Disabling indexing and doing your searches by way of the web interface is a more efficient approach performance wise.

share|improve this answer

In my case antivirus (MS Forefront) were a big problem with IMAP accounts and almost freezed Thunderbird often, try disabling them

share|improve this answer
    
I hadn't any antivirus. –  DevAntoine Sep 24 '13 at 13:09

The following steps helped me get Thunderbird working better with my (fairly large) GMail account:

  1. Disable TB Sync/Storage of the GMail 'All Mail' folder as this seems redundant (for me anyway)
  2. Do a 'Compact Folder' on the top-level GMail folder

TB's doing a LOT less disk IO and seems more responsive. IMHO, disabling real-time virus checking is not a valid option to improve performance.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.